質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.77%

HEROKUへpushがうまくできません・・プロキシでダメとか出てきます・・(><)

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 697

TOKUSABU

score 39

現在、作成中のアプリをgit push heroku masterにてpush
したいと思っております。

が・・・・今までは問題がなくできていましたが
今pushするとこんなのがでてきました

nter your Heroku credentials.
Email: *********@gmail.com
Password (typing will be hidden): 
 ▸    HTTP Error: https://api.heroku.com/login 400 Bad Request
 ▸    Invalid response from API.
 ▸    HTTP 400
 ▸    {*********@gmail.com **********}
 ▸    
 ▸    Are you behind a proxy?
 ▸    https://devcenter.heroku.com/articles/using-the-cli#using-an-http-proxy


どうやら
プロキシが影響してダメですと出てきます・・・
という事でググって解決方法はないか確認してみました
https://stackoverflow.com/questions/9648559/how-to-push-to-heroku-behind-a-proxy

なんとなく公開鍵の設定がうまく言っていない様子かな・・・?と思うのですが
具体的な方法がいまいちわかりません

なんかこんな方法とか参照リンクとか
アドバイスをいただく事は可能でしょうか?

何卒有識者の方々、お力をお借りしたく(;_;)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

heroku version の結果は、いくつでしょうか?

エラーメッセージで検索すると heroku client のバージョンが古いと API との通信でエラーになるようで、StackOverflow 等の回答でも「heroku cli をアップデートする」という回答が多く見つかります。

Error 400 when trying to connect Heroku keys
Intermittent heroku login failure 400 bad request

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/11 10:29

    返信大変ありがとうございます!!
    バージョンを確認したところ
    eroku-toolbelt/3.43.9 (x86_64-linux) ruby/2.3.0
    heroku-cli/5.2.39-010a227 (linux-amd64) go1.6.2
    You have no installed plugins.
    でした
    更新したのですが、うまくいかず・・・
    やはり公開鍵でしょうか・・?う〜ん
    このあたりを再度ためしてみます
    http://tusukuru.hatenablog.com/entry/2018/08/29/021651
    でもherokuアップデートでトラブルが多発しているんですね
    勉強になりました&アップデートもできました
    継続してエラー検討しまするm(_ _)m

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る