質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.34%

Railsを3.2から4.0にバージョンアップしたい

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,873

score 26

前提・実現したいこと

既存システムのRailsを3.2最新から4.0最新にバージョンアップしたい

発生している問題・エラーメッセージ

[~4.0_app]$ rbenv exec bundle update rails
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies........
Bundler could not find compatible versions for gem "rails":
  In Gemfile:
    spork-rails (>= 0) ruby depends on
      rails (< 3.3.0, >= 3.0.0) ruby

    rails (~> 4.0.13) ruby
Gemfileでgem 'spork-rails', '4.0.0'を指定して再度実行

[~4.0_app]$ rbenv exec bundle update rails
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies........
Bundler could not find compatible versions for gem "sass":
  In snapshot (Gemfile.lock):
    sass (= 3.2.1)

  In Gemfile:
    compass-rails (>= 0) ruby depends on
      compass (< 0.14, >= 0.12.2) ruby depends on
        sass (~> 3.1) ruby

    sass-rails (~> 4.0.0) ruby depends on
      sass (~> 3.2.2) ruby

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    railties (>= 3.1.0) ruby

    railties (< 5.0, >= 3.1.0) ruby

    railties (>= 3.0) ruby

    quiet_assets (>= 0) ruby depends on
      railties (~> 3.1) ruby

    rails (~> 4.0.13) ruby depends on
      railties (= 4.0.13) ruby

    coffee-rails (~> 4.0.0) ruby depends on
      railties (< 5.0, >= 4.0.0) ruby

    coffee-rails (~> 4.0.0) ruby depends on
      railties (< 5.0, >= 4.0.0) ruby
依存関係キリが無さそうだったのでbundle updateしたらアップデート完了しました。
[~4.0_app]$ rbenv exec bundle update
:
:
Bundle updated!
次はrakeコマンドで失敗するように
[~4.0_app]$ rake rails:update
rake aborted!
LoadError: cannot load such file -- ci/reporter/rake/rspec
/home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/activesupport-4.0.13/lib/active_support/dependencies.rb:229:in `require'
/home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/activesupport-4.0.13/lib/active_support/dependencies.rb:229:in `block in require'
/home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/activesupport-4.0.13/lib/active_support/dependencies.rb:214:in `load_dependency'
/home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/activesupport-4.0.13/lib/active_support/dependencies.rb:229:in `require'
/home/ore/workspace/app/Rakefile:9:in `<top (required)>'
(See full trace by running task with --trace)
上記はRakefileの以下をコメントアウトすることで解決

# require 'ci/reporter/rake/rspec'
その後be rake rails:updateを実行、マージした後、rails sをすると以下のようなエラーが出るようになる

=> Booting WEBrick
=> Rails 4.0.13 application starting in oreopment on http://0.0.0.0:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
Exiting
/home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/route_set.rb:430:in `add_route': Invalid route name, already in use: 'apl_new_login'  (ArgumentError)
You may have defined two routes with the same name using the `:as` option, or you may be overriding a route already defined by a resource with the same naming. For the latter, you can restrict the routes created with `resources` as explained here:
http://guides.rubyonrails.org/routing.html#restricting-the-routes-created
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:1484:in `add_route'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:1461:in `decomposed_match'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:1442:in `block in match'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:1433:in `each'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:1433:in `match'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:626:in `map_method'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:587:in `get'
        from /home/ore/workspace/4.0_app/config/routes.rb:33:in `block (4 levels) in <top (required)>'
        from /home/ore/.rbenv/versions/2.2.3/gemsets/rails4/gems/actionpack-4.0.13/lib/action_dispatch/routing/mapper.rb:877:in `block in constraints'

###補足情報(言語/FW/ツール等のバージョンなど)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • gouf

    2015/10/26 15:53

    Gemfile の内容はどのようになっていますか、公開可能でしょうか?

    キャンセル

  • babanrb

    2015/10/29 16:06

    すみません。Gemfileは公開不可です。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る