質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.65%

herokuデプロイ時, Precompiling assets failedが起こる問題

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 566

Romay

score 19

前提・実現したいこと

以前にも同じ質問をさせていただきましたが、解決しないのでもう一度させていただきます。
以前の質問

Railsアプリ製作中
Ruby 3.4.5
Rails 4.2.8
postgresql(heroku本番環境)
mysql(開発環境)

herokuへのデプロイは何回か成功済み。

本番環境でログアウトできない問題が起きたので、こちらの通りに進めていたところでエラーが起きました。

Heroku + Rails4.2 + Devise + Bootstrap3系列で本番環境でログアウト(Sign_out)ができない問題

rm -rf public/assets


でpublic/assetsを消し、

git push heroku master


の操作後にエラーになりました。

発生している問題・エラーメッセージ

以下エラー文該当箇所抜粋

rake aborted!
remote:        Sass::SyntaxError: Invalid CSS after "...heme.css.map */": expected selector or at-rule, was "{"version":3,"s..."
remote:          (in /tmp/build_d6cc61a71af5f196e061ff80c7dfc505/app/assets/stylesheets/application.scss)
remote:        (sass):8015

該当すると思われる、bootstrap-theme.css.mapを削除して入れ直してみましたが、変わりませんでした。

該当のソースコード

rm -rf public/assets


でpublic/assetsを消し、

git push heroku master


の操作後にエラーになりました。

以下該当可能性のあるファイル

assets/stylesheets/application.scss

/*
 * This is a manifest file that'll be compiled into application.css, which will include all the files
 * listed below.
 *
 * Any CSS and SCSS file within this directory, lib/assets/stylesheets, vendor/assets/stylesheets,
 * or vendor/assets/stylesheets of plugins, if any, can be referenced here using a relative path.
 *
 * You're free to add application-wide styles to this file and they'll appear at the bottom of the
 * compiled file so the styles you add here take precedence over styles defined in any styles
 * defined in the other CSS/SCSS files in this directory. It is generally better to create a new
 * file per style scope.
 *
 *= require_self
 *= require bootstrap-theme.css
 *= require bootstrap-theme.css.map
 *= require bootstrap-theme.min.css
 *= require bootstrap.css
 *= require bootstrap.css.map
 *= require bootstrap.min.css
 *= require main.css
 *= require responsive.css
 *= require profilecard.scss
 *= require font-awesome
 *= require linkmodal
 *= require jquery.kenburnsy.css

 *= require top.scss
 *= require users.scss
 *= require sign-up.css
 */

@import "bootstrap-sprockets";
@import "bootstrap";

以下 Rakefileです。

# Add your own tasks in files placed in lib/tasks ending in .rake,
# for example lib/tasks/capistrano.rake, and they will automatically be available to Rake.

require File.expand_path('../config/application', __FILE__)

Rails.application.load_tasks

試したこと

public/assetsを消しただけで、CSSはいじっていない(気づかずにタイプしている可能性はあるが)ので何が原因なのかわかりません。
compileの際に何かしらの問題が起こっているようですが、検索してもなかなか同じ問題が見つかりません。

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

 *= require bootstrap-theme.css.map
 *= require bootstrap.css.map

map ファイルを CSS として読み込もうとしてエラーになっていると思うので、この行を消してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/04 12:58

    コメントありがとうございます。おっしゃるようにそこがあやしいのですが、消してみても同じような以下のエラーがでてしまいました。
    rake aborted!
    remote: Sass::SyntaxError: Invalid CSS after "}": expected selector or at-rule, was "}"
    remote: (in /tmp/build_2ae95302fb3d699bf30c3a13d3e1674a/app/assets/stylesheets/application.scss)
    remote: (sass):20918

    キャンセル

  • 2019/04/05 12:15

    > : Sass::SyntaxError: Invalid CSS after "}": expected selector or at-rule, was "}"
    application.scssで独自のcssを書いている部分がありませんか?それがsassの構文になっていないようです。
    もしapplication.scssに書いていないならこのあたりで読み込んでいるsassの構文エラーになると思います。
    ```
    *= require top.scss
    *= require users.scss
    *= require sign-up.css
    ```

    キャンセル

  • 2019/04/07 15:24

    回答いただきありがとうございます。おっしゃるとおり、scssファイルにcssで記述している可能性はあります。ただ、今回の件は、gitでrollbackしエラー発生前まで戻って対応いたしました。コメントいただきありがとうございました。

    キャンセル

check解決した方法

-1

Gitでrollback処理し、エラー発生前まで戻るという処理を選択しました。
根本的な解決になっておりませんが、開発の関係上この手段を取りました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.65%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る