質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.49%

Laravel5.7→5.8にバージョンアップしたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,430

miyu94

score 12

現在ローカル環境で Laravel5.7 を使っていて、5.8にバージョンアップしたいです。

アップグレードガイドによると

composer.jsonファイル中のlaravel/frameworkパッケージのバージョンを5.8.*にアップデートしてください。

次に、アプリケーションで使用している3rdパーティーパッケージを調査し、Laravel5.8をサポートしているバージョンを使用していることを確認してください。

composer.json の "require" の中を "laravel/framework": "5.8.*",
にして composer dump-autoload しましたがバージョンが変わりません。

3rdパーティーパッケージ以外の部分は、GitHubにある最新のcomposer.jsonをコピーした方が良いでしょうか。

そもそもバージョンアップはどのような仕組みなのでしょうか。composer.json を書き換えるだけで、vendor下にあるLaravel本体コードが書き換わるのですか?

Laravelバージョンアップの方法を知っている方いましたらご教示願います。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

dump-autoloadはあくまでautoloader部分の変更に対する更新であって
composer.jsonの変更(パッケージの更新)に伴う指示はcomposer updateでは。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/28 17:58

    ありがとうございます。composer update 実行で5.8になりました。

    GitHubの最新 composer.json を見ると、"laravel/framework": "5.8.*",
    以外の部分にも変更があります。("require-dev"の"phpunit/phpunit": "^7.5"など)

    これらも全て手動で書き替えてcomposer updateすべきですか?

    キャンセル

  • 2019/03/28 18:44

    適宜、ですかね。そこはご自身の要件にあわせてご対応ください

    キャンセル

  • 2019/03/29 00:10

    わかりました。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる