本番環境にてconcurrent-ruby-1.1.5のエラーが発生

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 699

KOO_

score 21

こんにちは。

現在エラーが発生している点についてエラー内容がわからずお伺いしたく投稿させて頂きます。

ローカル環境では問題なく動作しているアプリを本番環境に移行した際、アプリケーションエラーが発生します。

エラー内容は以下の通りとなります。

Could not find concurrent-ruby-1.1.5 in any of the sources (Bundler::GemNotFound)

イメージ説明

インターネットで検索しても事例等が非常に少ないようで、更に今回のエラー投稿と別アプリケーションでも同様のエラーが発生しました。

どなたか原因を特定頂けないでしょうか?

よろしくお願い致します。

GEM
  remote: https://rubygems.org/
  specs:
    actioncable (5.2.2.1)
      actionpack (= 5.2.2.1)
      nio4r (~> 2.0)
      websocket-driver (>= 0.6.1)
    actionmailer (5.2.2.1)
      actionpack (= 5.2.2.1)
      actionview (= 5.2.2.1)
      activejob (= 5.2.2.1)
      mail (~> 2.5, >= 2.5.4)
      rails-dom-testing (~> 2.0)
    actionpack (5.2.2.1)
      actionview (= 5.2.2.1)
      activesupport (= 5.2.2.1)
      rack (~> 2.0)
      rack-test (>= 0.6.3)
      rails-dom-testing (~> 2.0)
      rails-html-sanitizer (~> 1.0, >= 1.0.2)
    actionview (5.2.2.1)
      activesupport (= 5.2.2.1)
      builder (~> 3.1)
      erubi (~> 1.4)
      rails-dom-testing (~> 2.0)
      rails-html-sanitizer (~> 1.0, >= 1.0.3)
    activejob (5.2.2.1)
      activesupport (= 5.2.2.1)
      globalid (>= 0.3.6)
    activemodel (5.2.2.1)
      activesupport (= 5.2.2.1)
    activerecord (5.2.2.1)
      activemodel (= 5.2.2.1)
      activesupport (= 5.2.2.1)
      arel (>= 9.0)
    activestorage (5.2.2.1)
      actionpack (= 5.2.2.1)
      activerecord (= 5.2.2.1)
      marcel (~> 0.3.1)
    activesupport (5.2.2.1)
      concurrent-ruby (~> 1.0, >= 1.0.2)
      i18n (>= 0.7, < 2)
      minitest (~> 5.1)
      tzinfo (~> 1.1)
    addressable (2.6.0)
      public_suffix (>= 2.0.2, < 4.0)
    annotate (2.7.4)
      activerecord (>= 3.2, < 6.0)
      rake (>= 10.4, < 13.0)
    archive-zip (0.12.0)
      io-like (~> 0.3.0)
    arel (9.0.0)
    bcrypt (3.1.12)
    bindex (0.5.0)
    bootsnap (1.4.1)
      msgpack (~> 1.0)
    breadcrumbs_on_rails (3.0.1)
    builder (3.2.3)
    byebug (11.0.1)
    capybara (3.15.0)
      addressable
      mini_mime (>= 0.1.3)
      nokogiri (~> 1.8)
      rack (>= 1.6.0)
      rack-test (>= 0.6.3)
      regexp_parser (~> 1.2)
      xpath (~> 3.2)
    carrierwave (1.3.1)
      activemodel (>= 4.0.0)
      activesupport (>= 4.0.0)
      mime-types (>= 1.16)
    childprocess (0.9.0)
      ffi (~> 1.0, >= 1.0.11)
    chromedriver-helper (2.1.1)
      archive-zip (~> 0.10)
      nokogiri (~> 1.8)
    coffee-rails (4.2.2)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0)
    coffee-script (2.4.1)
      coffee-script-source
      execjs
    coffee-script-source (1.12.2)
    concurrent-ruby (1.1.5)
    crass (1.0.4)
    devise (4.6.1)
      bcrypt (~> 3.0)
      orm_adapter (~> 0.1)
      railties (>= 4.1.0, < 6.0)
      responders
      warden (~> 1.2.3)
    erubi (1.8.0)
    execjs (2.7.0)
    ffi (1.10.0)
    font-awesome-rails (4.7.0.4)
      railties (>= 3.2, < 6.0)
    globalid (0.4.2)
      activesupport (>= 4.2.0)
    hashie (3.6.0)
    i18n (1.6.0)
      concurrent-ruby (~> 1.0)
    io-like (0.3.0)
    jbuilder (2.8.0)
      activesupport (>= 4.2.0)
      multi_json (>= 1.2)
    kaminari (1.1.1)
      activesupport (>= 4.1.0)
      kaminari-actionview (= 1.1.1)
      kaminari-activerecord (= 1.1.1)
      kaminari-core (= 1.1.1)
    kaminari-actionview (1.1.1)
      actionview
      kaminari-core (= 1.1.1)
    kaminari-activerecord (1.1.1)
      activerecord
      kaminari-core (= 1.1.1)
    kaminari-core (1.1.1)
    listen (3.1.5)
      rb-fsevent (~> 0.9, >= 0.9.4)
      rb-inotify (~> 0.9, >= 0.9.7)
      ruby_dep (~> 1.2)
    loofah (2.2.3)
      crass (~> 1.0.2)
      nokogiri (>= 1.5.9)
    mail (2.7.1)
      mini_mime (>= 0.1.1)
    marcel (0.3.3)
      mimemagic (~> 0.3.2)
    meta-tags (2.11.1)
      actionpack (>= 3.2.0, < 6.1)
    method_source (0.9.2)
    mime-types (3.2.2)
      mime-types-data (~> 3.2015)
    mime-types-data (3.2018.0812)
    mimemagic (0.3.3)
    mini_mime (1.0.1)
    mini_portile2 (2.4.0)
    minitest (5.11.3)
    msgpack (1.2.9)
    multi_json (1.13.1)
    nio4r (2.3.1)
    nokogiri (1.10.2)
      mini_portile2 (~> 2.4.0)
    oauth (0.5.4)
    omniauth (1.9.0)
      hashie (>= 3.4.6, < 3.7.0)
      rack (>= 1.6.2, < 3)
    omniauth-oauth (1.1.0)
      oauth
      omniauth (~> 1.0)
    omniauth-twitter (1.4.0)
      omniauth-oauth (~> 1.1)
      rack
    orm_adapter (0.5.0)
    public_suffix (3.0.3)
    puma (3.12.1)
    rack (2.0.6)
    rack-test (1.1.0)
      rack (>= 1.0, < 3)
    rails (5.2.2.1)
      actioncable (= 5.2.2.1)
      actionmailer (= 5.2.2.1)
      actionpack (= 5.2.2.1)
      actionview (= 5.2.2.1)
      activejob (= 5.2.2.1)
      activemodel (= 5.2.2.1)
      activerecord (= 5.2.2.1)
      activestorage (= 5.2.2.1)
      activesupport (= 5.2.2.1)
      bundler (>= 1.3.0)
      railties (= 5.2.2.1)
      sprockets-rails (>= 2.0.0)
    rails-dom-testing (2.0.3)
      activesupport (>= 4.2.0)
      nokogiri (>= 1.6)
    rails-html-sanitizer (1.0.4)
      loofah (~> 2.2, >= 2.2.2)
    railties (5.2.2.1)
      actionpack (= 5.2.2.1)
      activesupport (= 5.2.2.1)
      method_source
      rake (>= 0.8.7)
      thor (>= 0.19.0, < 2.0)
    rake (12.3.2)
    rb-fsevent (0.10.3)
    rb-inotify (0.10.0)
      ffi (~> 1.0)
    regexp_parser (1.3.0)
    responders (2.4.1)
      actionpack (>= 4.2.0, < 6.0)
      railties (>= 4.2.0, < 6.0)
    ruby_dep (1.5.0)
    rubyzip (1.2.2)
    sass (3.7.3)
      sass-listen (~> 4.0.0)
    sass-listen (4.0.0)
      rb-fsevent (~> 0.9, >= 0.9.4)
      rb-inotify (~> 0.9, >= 0.9.7)
    sass-rails (5.0.7)
      railties (>= 4.0.0, < 6)
      sass (~> 3.1)
      sprockets (>= 2.8, < 4.0)
      sprockets-rails (>= 2.0, < 4.0)
      tilt (>= 1.1, < 3)
    selenium-webdriver (3.141.0)
      childprocess (~> 0.5)
      rubyzip (~> 1.2, >= 1.2.2)
    slim (3.0.9)
      temple (>= 0.7.6, < 0.9)
      tilt (>= 1.3.3, < 2.1)
    slim-rails (3.1.3)
      actionpack (>= 3.1)
      railties (>= 3.1)
      slim (~> 3.0)
    spring (2.0.2)
      activesupport (>= 4.2)
    spring-watcher-listen (2.0.1)
      listen (>= 2.7, < 4.0)
      spring (>= 1.2, < 3.0)
    sprockets (3.7.2)
      concurrent-ruby (~> 1.0)
      rack (> 1, < 3)
    sprockets-rails (3.2.1)
      actionpack (>= 4.0)
      activesupport (>= 4.0)
      sprockets (>= 3.0.0)
    sqlite3 (1.4.0)
    temple (0.8.1)
    thor (0.20.3)
    thread_safe (0.3.6)
    tilt (2.0.9)
    turbolinks (5.2.0)
      turbolinks-source (~> 5.2)
    turbolinks-source (5.2.0)
    tzinfo (1.2.5)
      thread_safe (~> 0.1)
    uglifier (4.1.20)
      execjs (>= 0.3.0, < 3)
    warden (1.2.8)
      rack (>= 2.0.6)
    web-console (3.7.0)
      actionview (>= 5.0)
      activemodel (>= 5.0)
      bindex (>= 0.4.0)
      railties (>= 5.0)
    websocket-driver (0.7.0)
      websocket-extensions (>= 0.1.0)
    websocket-extensions (0.1.3)
    wysiwyg-rails (2.9.3)
      railties (>= 3.2, < 6.0)
    xpath (3.2.0)
      nokogiri (~> 1.8)

PLATFORMS
  ruby

DEPENDENCIES
  annotate
  bootsnap
  breadcrumbs_on_rails
  byebug
  capybara (>= 2.15)
  carrierwave
  chromedriver-helper
  coffee-rails (~> 4.2)
  devise
  font-awesome-rails
  jbuilder (~> 2.5)
  kaminari
  listen (>= 3.0.5, < 3.2)
  meta-tags
  omniauth-twitter
  puma (~> 3.11)
  rails (~> 5.2.2)
  sass-rails (~> 5.0)
  selenium-webdriver
  slim-rails (= 3.1.3)
  spring
  spring-watcher-listen (~> 2.0.0)
  sqlite3
  turbolinks (~> 5)
  tzinfo-data
  uglifier (>= 1.3.0)
  web-console (>= 3.3.0)
  wysiwyg-rails

BUNDLED WITH
   2.0.1
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

こちらの件ですが、現在も解決できない状態でしょうか。何かしら環境の違いにより、依存関係の問題が発生してそうな状況と思われます。

似たようなケースがこちらのブログにまとめられていました。こちらのページに記載されているいくつかのコマンドを実行し、現在の環境が適切かどうかや、動作状況についてご確認をされてみてはいかがでしょうか。

http://startonlineeikaiwa.com/programming/2017/01/18/rails-server%E5%AE%9F%E8%A1%8C%E2%86%92%E3%80%8Crun-bundle-install-to-install-missing-gems-%E3%80%8D%E2%86%92bundle-update%E3%81%A7%E8%A7%A3%E6%B1%BA/

投稿

さくらインターネット コミュニティ、Developer Advocate
  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる