質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

Ruby Devkitがインストールできない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 3,576

666_paru

score 18

初心者で全然わからない状態なので、力を貸してほしいです。

やりたいことは、新品のWindows10にRuby 、railsの環境を構築したいです。
Cofee-cup(https://www.coffee-cup.com/mugcups/windows_rails)というサイトの通りにRuby をインストールし、Devkitを解凍までできました。
その後、コマンドプロンプトにて¥DevKit¥devkitvarsと入力すると、
'¥DevKit¥devkitvars' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。
と表示されます。
Windowsの設定等何も変えず、ここまで指示通りにしてきました。

バージョンは
Ruby インストーラーのアーカイブから落としました
Ruby はバージョンは一番上の2.6.1-1です
Devkitは DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exeです

コマンドプロンプトでDevkitのフォルダまで移動し¥DevKit¥devkitvarsと入力すると
指定されたパスが見つかりません。
とでます。管理署として実行してもダメでした。
PATHが通ってないということみたいですが、スクショでは¥DevKit¥devkitvarsがPATHを通すコードのようですが、その認識は違うのでしょうか?

その後、別のサイトも見ながら
ruby dk.rb init
ruby dk.rb install
を入力する前に
gem update --system
を入力しました。どうやらこれはできたようで、今入力すると
Latest version already installed. Done.
とでます。
これでインストールできている状態なんでしょうか?

一回全部アンインストールして、Ruby とDevkitセットの入れたほうが早いですか?
また同じ殊にならないでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

参考にされているサイトの情報が古いです。

以下のサイトを参考にインストールしてください。

Rubyのダウンロードとインストール

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/24 22:12

    凄くわかりやすいサイトを教えていただきありがとうございます。

    現在とかなり違うようですね、、、

    キャンセル

checkベストアンサー

0

ここまで指示通りにしてきました。 

と言いながら、

Ruby はバージョンは一番上の2.6.1-1です

これが指示通りでは無い。

2.6をインストールしたのなら、Ruby本体のインストールに引き続いて、Devkitのインストール画面(コマンドプロンプト画面で、1, 2, 3 を選べ見たいな画面)が出るので、1 2 3 を順に選べばDevkitがインストールできます。

そこを飛ばしてしまったのなら、Rubyをインストールしたディレクトリの中のbinディレクトリに、ridk.cmdというのがあるので、ridk installとして、1 2 3 を選びます。

C:\>cd \Ruby26\bin
C:\Ruby26\bin>ridk install

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/24 22:08

    確かに違うものをインストールしていました。
    1.2.3とやってみて、インストールできたようです。

    教えていただきありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る