質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

RoRでのmysqlのエラー

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,466
退会済みユーザー

退会済みユーザー

railsで新しいプロジェクトを作成しようとし、
rails new ○○ -d mysql
を実行したあとそのディレクトリ移動し
gemファイルを gem 'mysql2', '0.3.18' に書き換えてbundle installをしたのですが、以下のようなエラーが出てしまい先に進めません。
どなたかよろしくお願いいたします。
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /Users/Hiroki/.rbenv/versions/2.1.3/bin/ruby extconf.rb
checking for ruby/thread.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/Hiroki/.rbenv/versions/2.1.3/bin/ruby
/Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:456:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
You have to install development tools first.
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:587:in `try_cpp'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:1067:in `block in have_header'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:918:in `block in checking_for'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:351:in `block (2 levels) in postpone'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:321:in `open'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:351:in `block in postpone'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:321:in `open'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:347:in `postpone'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:917:in `checking_for'
    from /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/2.1.0/mkmf.rb:1066:in `have_header'
    from extconf.rb:9:in `<main>'

extconf failed, exit code 1

Gem files will remain installed in /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/mysql2-0.3.18 for inspection.
Results logged to /Users/Hiroki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/extensions/x86_64-darwin-14/2.1.0-static/mysql2-0.3.18/gem_make.out
An error occurred while installing mysql2 (0.3.18), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.3.18'` succeeds before bundling.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

OS はMac ですね?

brew を導入し、mysql をインストールすると解決できるかもしれません

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew update # パッケージインストール情報を更新
brew install mysql


Failed to build gem native extension.

上のエラーはおおよその場合、gem が必要としている依存ライブラリがインストールされていない場合に発生します

gem がどのライブラリに依存しているか調べてみると、解決の糸口がつかめるかもしれません

何か参考になれば幸いです

# Links

Homebrew — OS X 用パッケージマネージャー
MacOSX - パッケージ管理システム Homebrew - Qiita

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

MacOSXはSierraでしょうか?
それだとconfigに以下の追記が必要と思われます。僕もはまりました。

bundle config --local build.mysql2 "--with-ldflags=-L/usr/local/opt/openssl/lib --with-cppflags=-I/usr/local/opt/openssl/include"


こことか参考になるかと。
RailsプロジェクトでMySQLがbundle installできなかった

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る