質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.99%

capistrano3のdeploy:checkでWARNが出ていますが意味が不明で対処出来ないのでご教示お願いします。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 194

koume

score 156

Railsアプリをcapistrano3でデプロイしようとトライしています。

VPSの環境は以下のように設定しています。
VPS=さくらのVPS
ruby2.3.1-p112 ($ ruby -v で 2.3.1p112と表示)
rails 5.1.3 ($ rails -v で 5.3.1と表示)
Apache
passenger
MariaDB
鍵認証でのログイン可能
firewallの設定完了
SSHの設定変更完了
SSL証明書Let's Encryptのインストール完了(httpsアクセス確認完了)
postfixのインストール完了
DNSの設定完了

追記
VPSにRubyをインストールする際、「$ rvm install 2.3.1」 でインストールしています。

[vagrant@localhost chibi]$ bundle exec cap production deploy:check を
実行しデプロイのチェックをしましたが以下のようにWARNが表示されてしまいます。

[vagrant@localhost chibi]$ bundle exec cap production deploy:check

 DEBUG [298c0a92] Running [ -d /usr/local/rbenv/versions/2.3.1-p112 ] as panda@XXXX-XXXX.com
 DEBUG [298c0a92] Command: [ -d /usr/local/rbenv/versions/2.3.1-p112 ]

Enter passphrase for /home/vagrant/.ssh/id_rsa: (#パスフレーズを入力)

 DEBUG [ac41f77b] Finished in 75.550 seconds with exit status 1 (failed).
  WARN rbenv: 2.3.1-p112 is not installed or not found in /usr/local/rbenv/versions/2.3.1-p112 on panda@XXXX-XXXX.com


capistrano3のrbenvに関するコードはconfig/deploy.rbに記述しています。

config/deploy.rb

set :rbenv_type, :user
set :rbenv_path, '/usr/local/rbenv'
set :rbenv_ruby, '2.3.1p112'
set :chruby_ruby, 'ruby-2.3.1p112'
set :rbenv_prefix, "RBENV_ROOT=#{fetch(:rbenv_path)} RBENV_VERSION=#{fetch(:rbenv_ruby)} #{fetch(:rbenv_path)}/bin/rbenv exec"
set :rbenv_map_bins, %w{rake gem bundle ruby rails}
set :rbenv_roles, :all
config/deploy/production.rb

server 'XXXX-XXXX.com', user: 'panda', roles: %w{app web db} (#VPSの設定)

set :ssh_options, {
  port: 60354, (#VPSのポート番号)
  keys: %w(/home/vagrant/.ssh/id_rsa), (#仮想マシンの秘密鍵を指定)
  forward_agent: true,
  auth_methods: %w(publickey)
}


WARNでnot installedとなっているのでインストールできなかったというのはなんとなくわかります。
config/deploy.rbのset :rbenv_ruby, '2.3.1p112'の部分でWARNになっているみたいなのです。

①自分のVPSにすでにruby2.3.1p112はインストールされているからinstallできません。という警告なのか?

②それともVPSにインストールされていませんという警告なのか?

③VPSにrvmでインストールしているのでdeploy.rbの記述が違っているのか?

もし①の場合はconfig/deploy.rbのコードを削除すれば解決するものなのでしょうか?

②の場合はproduction.rbの設定が間違っているのでしょうか?
たとえば'XXXX-XXXX.com'の部分はIPアドレスを記入しなければいけない。
user: 'panda'はVPSのログインユーザー名ではないのか?

③の場合どのように記述すればいいのか?

などデプロイは初めてで的外れな質問をしているかもしれませんが宜しくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

deploy.rbのset :rvenvに関するコードを全てコメントアウトしset :rvm_ruby_version, "ruby-2.3.1"
を追記して解決しました。
原因はVPS側にrubyをインストールする際にrvenvではなくrvmでインストールしていたのでrvenvは
ありませんということが原因だったのでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる