質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

Rubyがクラッシュした?

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,748

score 29

railsでmysqlのgemが入らないエラーが発生したので、こちらのページにある
https://github.com/brianmario/mysql2/issues/1005
gem install mysql2 -- --with-opt-dir="$(brew --prefix openssl)"

このコマンドを打ったら、Rails sのときに

Don't forget to include the Crash Report log file under
DiagnosticReports directory in bug reports.

というエラーが発生するようになりました。。。

Rubyを再インストールしても治らないのでどこが原因かなと困っています。

どなたか原因らしきものでもわかったら教えていただけたら助かります

Githubに上がってたのをクローンしてきて、同じようにクローンした人は動いているのでRailsのバージョンではなさそうです

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

その情報だけで原因特定は無理かと・・
railsのバージョンかもしれないですし、記事にはmacのOSの不具合なども出てますし・・
一度mysql2をgemからuninstall(コマンドありましたっけ?最近rails書いてないから忘れた)してサーバー立てられるか検証してみては?

--with-opt-dir="$(brew --prefix openssl)"
あと引数のオプションとか理解されてますか?
今回入らなかった件にbrewのopensslが関係されていたんですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/22 10:35

    ありがとうございます!
    オプションの意味などは理解していたつもりだったのですが、実際に何が起きるまでは理解できていませんでした。
    ひとまず違うRubyのバージョンのプロジェクトがサーバー建てられるかどうかだけ検証して、その後mysql2のgemのアンインストールをしたいと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る