質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.07%

git push heroku master できない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,198

aiai8976

score 64

前提・実現したいこと

https://djangogirlsjapan.gitbook.io/workshop_tutorialjp/deploy を使ってDjangoの勉強をしているのですが、push時にエラーが出て行き詰っています。
考えられる解決策がある方はいないでしょうか。

発生している問題・エラーメッセージ

djangogirls ➤ git push heroku master                                                       git:mastershell returned 127
Enumerating objects: 21, done.                                                                        │
Counting objects: 100% (21/21), done.                                                                 │Press ENTER or type command to continue
Delta compression using up to 4 threads                                                               │zsh:1: command not found: q
Compressing objects: 100% (18/18), done.                                                              │
Writing objects: 100% (21/21), 4.68 KiB | 1.56 MiB/s, done.                                           │shell returned 127
Total 21 (delta 0), reused 0 (delta 0)                                                                │
remote: Compressing source files... done.                                                             │Press ENTER or type command to continue
remote: Building source:                                                                              │(myvenv) djangogirls ➤ ls                                                                           
remote:                                                                                               │Procfile         db.sqlite3       mysite           requirements.txt                                 
remote: -----> Python app detected                                                                    │blog             manage.py        myvenv
remote:  !     Requested runtime (python-3.5.2) is not available for this stack (heroku-18).          │(myvenv) djangogirls ➤ rm Procfile                                                                  
remote:  !     Aborting.  More info: https://devcenter.heroku.com/articles/python-support             │rm: Procfile: is a directory
remote:  !     Push rejected, failed to compile Python app.                                           │(myvenv) djangogirls ➤ rd Procfile                                                                  
remote:                                                                                               │(myvenv) djangogirls ➤ ls                                                                           
remote:  !     Push failed                                                                            │blog             manage.py        myvenv
remote: Verifying deploy...                                                                           │db.sqlite3       mysite           requirements.txt                                                  
remote:                                                                                               │(myvenv) djangogirls ➤ vim Procfile                                                                 
remote: !       Push rejected to akiyamas-app.                                                        │(myvenv) djangogirls ➤ ls                                                                           
remote:                                                                                               │Procfile         db.sqlite3       mysite           requirements.txt                                 
To https://git.heroku.com/akiyamas-app.git                                                            │blog             manage.py        myvenv
 ! [remote rejected] master -> master (pre-receive hook declined)                                     │(myvenv) djangogirls ➤ pwd                                                                          
error: failed to push some refs to 'https://git.heroku.com/akiyamas-app.git' 

該当のソースコード

djangogirls ➤ git push heroku master

試したこと

調べていたところ、psycopgをアップデートすれば直ったと書いている記事があったので試して見ましたが変わりませんでした。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

エラーメッセージの通り、python-3.5.2 が利用できないことが原因ではないでしょうか?

Heroku で利用できる Python のバージョンは以下のリンク先から確認できます。

https://devcenter.heroku.com/articles/python-support

Supported runtimes
python-3.7.2 on all (cedar-14, heroku-16, and heroku-18) runtime stacks
python-3.6.8 on all (cedar-14, heroku-16, and heroku-18) runtime stacks
python-2.7.16 on all (cedar-14, heroku-16, and heroku-18) runtime stacks

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/19 16:27

    回答ありがとうございます。
    対応しているpythonのバージョンがあるのは知らなかったです。
    変更後、無事できました。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.07%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る