質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.20%

npm ERR! peer dep missing ~ のエラーを解決したい

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 3,660

miranofoo

score 13

前提・実現したいこと

VScodeがクラッシュ?または更新?があってから、ng serve をするとエラーがでるようになってしまった。
npm ls をしてみたところ、以下のようなエラーがでていました。

エラーメッセージ
npm ERR! peer dep missing: @angular/common@^2.2.3, required by @angular/flex-layout@2.0.0-rc.1
npm ERR! peer dep missing: @angular/common@^5.0.0, required by angular2-drag-scroll@1.5.2
npm ERR! peer dep missing: @angular/compiler@^5.0.0, required by angular2-drag-scroll@1.5.2
npm ERR! peer dep missing: @angular/core@^2.2.3, required by @angular/flex-layout@2.0.0-rc.1
npm ERR! peer dep missing: @angular/core@^5.0.0, required by angular2-drag-scroll@1.5.2
npm ERR! peer dep missing: zone.js@^0.7.2, required by @angular/flex-layout@2.0.0-rc.1
npm ERR! peer dep missing: @angular/cdk@2.0.0-beta.12, required by @angular/material@2.0.0-beta.12

試したこと

・上記のものをインストールし直した → 何故かインストールができない
・node_modulesの削除 → キャッシュクリーン → npm install
・Angularcilを入れ直した
・npmのバージョンをあげてみた(通常は3.10.9です)

補足情報(FW/ツールのバージョンなど)

npm:3.10.9
node:6.9.2
webpack:1.14.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

errorみるとそもそものangularのバージョンが古いっぽいです。
magendaさんの話通りに

  1. global のnodeをアップデート
  2. node modules消す
  3. angular cli(global と localともに)
  4. package lockもアップデート「cli対応 module以外も対応させる

くらいでいけるとおもいます

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/18 13:11

    初歩的な質問で申し訳ないのですが、今までこのバージョンで動いていたのですが急に動かなくなる事ってよくあるんですか?
    また、Angularのバージョンは変えずに動かす方法などはありますでしょうか?

    キャンセル

  • 2019/03/20 15:48

    新しくライブラリ入れたりした時に、入れたライブラリが他のパッケージと依存している時に起きることがあると思ってます。

    今回のケースでいうと、
    angularのflex layoutとangular materialを入れた事が原因かと。

    元々入っていたangularのバージョンが古いためmaterialとflexが使えません依存エラーみたいに思ってもらえると理解が捗ると思います。

    バージョンの管理ファイルは
    yarn.lockかpackage.lock.jsonが該当します。

    答えになってるかな??

    キャンセル

  • 2019/03/25 09:57

    ありがとうございました。
    原因が分かって良かったです。

    キャンセル

+1

npmを最新バージョンにしてもう一度node_modulesの削除とかの作業をやりなおしてみてはいかがでしょーか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/18 10:41

    npm install -g npm(バージョン6.9.0) → node_modules削除 → npm cache clean --force → npm install

    回答ありがとうございます。
    上記の工程をやってみたのですが、変わらずエラーがでてしまいました。

    npm WARN @angular/flex-layout@2.0.0-rc.1 requires a peer of @angular/common@^2.2
    .3 but none is installed. You must install peer dependencies yourself.
    npm WARN @angular/flex-layout@2.0.0-rc.1 requires a peer of @angular/core@^2.2.3
    but none is installed. You must install peer dependencies yourself.
    npm WARN @angular/flex-layout@2.0.0-rc.1 requires a peer of zone.js@^0.7.2 but n
    one is installed. You must install peer dependencies yourself.
    npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/cdk@2.0.0-b
    eta.12 but none is installed. You must install peer dependencies yourself.
    npm WARN angular2-drag-scroll@1.5.2 requires a peer of @angular/common@^5.0.0 bu
    t none is installed. You must install peer dependencies yourself.
    npm WARN angular2-drag-scroll@1.5.2 requires a peer of @angular/compiler@^5.0.0
    but none is installed. You must install peer dependencies yourself.
    npm WARN angular2-drag-scroll@1.5.2 requires a peer of @angular/core@^5.0.0 but
    none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules\fse
    vents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
    1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}
    )

    audited 10566 packages in 16.583s
    found 25 vulnerabilities (13 low, 5 moderate, 7 high)
    run `npm audit fix` to fix them, or `npm audit` for details

    キャンセル

  • 2019/03/18 10:59

    依存関係の警告でてますねー
    各パッケージもアップデートしてみてはいかがでしょーか

    キャンセル

  • 2019/03/18 15:52

    各パッケージのアップデートをしたのですがエラー変わりませんでした・・
    やり方が何か違っているのでしょうか?
    npm update @angular/common を上から全て行いました。

    キャンセル

0

npm run ng -- serve


で、localのngコマンドでserveする

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.20%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る