質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.65%

BLENano2(nRF52832)でのBLE通信ができません(Arduino,Mbed,SDK)

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,110

46psm

score 14

前提・実現したいこと

私は今、BLENano2と呼ばれるBLEモジュールを用いて開発を行っています。
そこでIPhone8とのBLE通信を行おうと考えています。

開発環境として"Nordic SDK 15.0.0"を用いて、keilというIDEで開発を行います。
また、IPhoneでは"nRFconnect"というアプリでスキャンします。

セントラル:IPhone8
ペリフェラル:BLENano2

発生している問題・エラーメッセージ

SDKBLEの関数を使用するにはソフトデバイス(s132)をBLENano2に書き込まないといけません。
ソフトデバイスの書き込み方法が分からないため、ほかの方法を試そうとArduinoとMbedのサンプルプログラムで試しましたが、両方ともBLE通信を行うことができませんでした。
nRFconnectでスキャンしてもデバイスを見つけることができませんでした。

試したこと

まず、BLENano2にファームウェア(v1.0)を書き込みました。
ArduinoもMbedも初めにBLENano2についているLED(D13)でのLチカプログラム(Blinkyみたいな名前のもの)で動作確認を行ったので、設定ミスではないと思われます。

Arduinoのセットアップはこちらを参考にしました。
Mbedはこちらを参考にしました。

またIPhone8側の操作としては、「設定」→「Bluetooth」でのペアリングしてあるものを事前に外しました。その後、BluetoothをOnにしてnRFconnectを起動してScanを開始します。

 

MbedはBLEのライブラリが全く動かないということを書いてある記事があったのでしょうがないかとは思いますが、ArduinoでBLE接続ができないのは何か原因があるのでしょうか?

追記

[SDK]
BLENano2のソフトデバイス書き込み方法は、本当に正しいのかはわからないのですが、ドラッグアンドドロップすればよいだけとのことでした。
しかしそれでもBLE通信が開始されることはありませんでした。

[Arduino]
"BLE_beacon"のプログラムでシリアルモニタで動作状況を確認しました。
おそらく"ble.startAdvertising();"でセントラル側へアドバタイズするのですが、その後の行やloopの中でSerial.plintlnで動作状況を確認しても、シリアルモニタに表示されるので、プログラムは正常に動いていると考えられます。
しかし、セントラル側でスキャンしようとしてもBLE通信可能デバイスとして検出されません。
iPhoneだけではなく、Android(Android4.4 API19)でも試してみました。Androidでも結果は変わらず、検出されませんでした。
Androidは自作のアプリで試しました。ほかのBLE通信デバイスとの接続確認済みなのでプログラムが原因ではなさそうです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mt08

    2019/03/26 03:41

    Nordic SDKのサンプルコードは、試しましたか?

    キャンセル

  • 46psm

    2019/03/26 13:02

    返信ありがとうございます。
    Nordic SDKのBLE_peripheralのサンプルコードはいくつか試しました。
    先にソフトデバイスを書き込んでから、SDKのプログラム内容を変更することなく"ble_app_blinky"や"ble_app_beacon"を書き込んでみたのですがセントラル側での端末でスキャンされることはありませんでした。

    ソフトデバイスの書き込み方に原因があるのか、SDKサンプルコードそのままでは使用できないのか、それとも他に原因があるのか、調べてもあまり出てこないのですが調査中です。

    キャンセル

回答 3

checkベストアンサー

+1

46psmさん、

Nordic SDK のサンプルコードのフォルダの、nRF5_SDK_15.3.0_59ac345/examples/ble_peripheral/ble_app_hrs/hex/フォルダ内にある、ble_app_hrs_pca10040_s132.hex をドラッグアンドドロップして、BLENano2に焼いて、nRF Connectアプリで、Nordic_HRM というのが見え、接続(Connect)もできました。

とりあえず、無線の動作は、↑のHEXファイルで、確認できると思います。

  • 更新(2019-0327)
    こんな感じに、Nordic_HRMというデバイスが見えます。(BLENano2は、ラップトップPCに挿しっぱなし)
    イメージ

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/27 16:28 編集

    mt08さん
    回答ありがとうございます。

    書いてある通りにやってみたのですが、nRF Connectアプリで表示されることはありませんでした。

    手順の確認ですが、
    1. BLENano2にソフトデバイスをドラッグアンドドロップで書き込む。
     (s132_nrf52_6.0.0/s132_nrf52_6.0.0_softdevice.hex)
    2. BLENano2にサンプルコードをドラッグアンドドロップで書き込む。
     (nRF5_SDK_15.0.0_a53641a/examples/ble_peripheral/ble_app_hrs/hex/ble_app_hrs_pca10040_s132.hex)
    3. 直流電源のマイナスとGNDピン、プラスとVDDピンを接続して3.3V供給
    4. iPhone8でnRF ConnectアプリでSCAN

    で間違っていないですよね。()内は自分の環境のバージョンです。
    細かいようで申し訳ございません。
    これでできていないとなるとチップの破損等を疑った方がよいでしょうか。

    キャンセル

  • 2019/03/27 16:38

    ble_app_hrs_pca10040_s132.hexに、softdeviceは含まれているので、このファイルのみで大丈夫ですね。
    (両方のファイルを開いて、比較すると..)
    ファイルを書き込んだあとはリセットがかかって、USBから電源が供給されてるので、書き込んだプログラムが動きはじめます。
    ので、そのままで、電波を出してるはずなんですけどね。。。

    キャンセル

  • 2019/03/27 17:18

    返信ありがとうございます。
    予備として購入していたもう一つのBLENano2で試した結果、nRF Connectで無事スキャンすることができました。
    方法はmt08さんのおっしゃる通りでやりました。
    一つ目のBLENano2ではなぜ無線通信ができないのかは謎ですが、とりあえず解決とさせていただきます。
    本当にありがとうございました。

    キャンセル

+1

46psmさん、

NordicのHRMサンプルが動いた、ということで、ちょっと説明します。(別の回答として書きます。)

SoftDeviceは、nRF52チップ内のFLASHメモリのアドレス 0x0_0000から、配置されます。
SDK v15のSoftDevice S132だと、アドレス 0x0_0000 - 0x2_5FFFの 152KBが使用されます。

なので、ユーザアプリケーションは、0x2_6000 から配置することになります。
SoftDevice用のRAMのエリアも、ユーザアプリとかぶらないようにしないといけません。

Keil MDK-ARMを使っているということなので、
examples\ble_peripheral\ble_app_hrs\pca10040\s132\arm5_no_packs\ の
ble_app_hrs_pca10040_s132.uvprojx をダブルクリックして、プロジェクトを開いてください。

ALT+[F7] で、プロジェクトのオプションのウィンドウを開いて、[Target]タブを見ると、
IROM1のとこで、Start=0x26000 , Size=0x5A000
IRAM1のとこで、Start=0x20002B90 , Size=0xD470
というのが見れますが、これが、ユーザが使う(使える)領域になります。

Options

で、普通にサンプルをビルドすると、0x26000から始まる、アプリだけの hex が生成されるので、それを、components\softdevice\s132\hex にある、s132_nrf52_6.1.1_softdevice.hex と合体させて、さいごにできた hex をドラッグアンドドロップすれば、動くはずです。

私は、srec_cat.exe というのを使って、SDのhexとユーザアプリのhexをくっつけました。前に↓の記事に書いたので、関連箇所を参考にしてみてください。nRF51の記事ですが、基本的に同じですね。
https://qiita.com/mt08/items/39359239a4b68caeadb5

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/02 15:24

    mt08さん
    ちょうど今どうしようかと思っていたことを書いていただき本当にありがとうございます!
    nRF52でもsrec_cat.exeを使用してhexをくっつけ、動作させることができました。
    本当にありがとうございます。

    キャンセル

0

単純にググると
nRF52のSoftDeviceについて
の記事が。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/14 15:03

    MasahikoHirata様
    回答ありがとうございます。
    自分が調べてもこのサイトにたどり着かなかったので助かります!
    記事がnRF51822のやつなので手順通りに行っても"Cortex-M4"というエラーが表示されてしまうのでもう少し検討させていただきます。

    キャンセル

  • 2019/03/14 15:15

    ちなみに私もNano2は以前使いましたがarduino IDEでは簡単でした。

    キャンセル

  • 2019/03/14 16:01

    Arduinoのサンプログラムでも動かなかったのですが、Nano2自身が壊れている可能性を考えた方がいいですか?
    一応SDKではLチカやSPI通信などはできましたし、ArduinoではLチカはできるのですが、、、
    セントラル側のIPhoneもほかのデバイスはスキャンできるのでNano2のBLEのみが使えないんですよね

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.65%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる