質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.80%

dockerで作成したnginxコンテナとrailsコンテナの接続がうまくいかない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,441

Daimian

score 50

前提・実現したいこと

docker-compose + nginx + Rails + mysqlという環境でアプリを作成し、起動させたいです。

発生している問題・エラーメッセージ

下記の「該当のソースコード」に記載の状態でdocker-compose upをし、localhostにアクセスしますが、nginxがrailsコンテナを見に行っている気配がありません。

localhost:3000だと問題なくrailsの「Yay! You’re on Rails!」というオープニング画面が表示されますが、localhostに接続するとWelcome to nginx!と、nginxのオープニング画面が出て来ます。

また、設定しているroutingで/api/v1/lightning/2018というのがあり、これを
http://localhost:3000/api/v1/lightning/2018 で実施すると問題なくdbからデータを取って来ますが、
http://localhost/api/v1/lightning/2018 で実施すると「404 Not Found nginx/1.15.9」というメッセージが返って来てしまいます。
その時は

2019/03/04 12:37:28 [error] 6#6: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 172.28.0.1, server: localhost, request: "GET /api/v1/lightning/2018 HTTP/1.1", upstream: "http://127.0.0.1:3000/api/v1/lightning/2018", host: "localhost"
2019/03/04 12:37:28 [error] 6#6: *2 open() "/app/kaminari_API/kaminari_API_rails/public/500.html" failed (2: No such file or directory), client: 172.28.0.1, server: localhost, request: "GET /api/v1/lightning/2018 HTTP/1.1", upstream: "http://127.0.0.1:3000/api/v1/lightning/2018", host: "localhost"


と表示されます。

該当のソースコード

docker_compose.yml

version: '3'

services:
  nginx:
    image: nginx:latest
    container_name: kaminari_nginx
    ports:
      - "80:80"
    links:
      - web
    volumes:
      - ./kaminari_nginx/nginx.conf:/etc/nginx/nginx.conf

  web:
    build:
      context: ./
      dockerfile: Dockerfile_API
    tty: true
    stdin_open: true
    container_name: kaminari_API
    environment:
      RAILS_ENV: development
    volumes:
      - ./kaminari_API/kaminari_API_rails:/app/kaminari_API/kaminari_API_rails:rw
      - ./start_api.sh:/usr/local/bin/start_api.sh:ro
    ports:
      - 3000:3000
    working_dir: /app/kaminari_API/kaminari_API_rails
    command: bash /usr/local/bin/start_api.sh

  db:
    image: mariadb:latest
    container_name: kaminari_db
    ports:
      - 3307:3306
    environment:
      MYSQL_DATABASE: kaminari_API_rails_development

./kaminari_nginx/nginx.conf

user  nginx;
worker_processes  auto;

error_log  /var/log/nginx/error_test.log debug;
pid        /var/run/nginx.pid;

events {
    worker_connections  1024;
}

http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access_test.log  main;

    sendfile        on;
    #tcp_nopush     on;

    keepalive_timeout  65;

    gzip  on;

    server {
        listen      80;
        server_name  localhost;

        root /app/kaminari_API/kaminari_API_rails/public;

        location / {
            proxy_pass http://app_server;
            proxy_set_header Host $http_host;
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header Client-IP $remote_addr;
            proxy_set_header X-Forwarded-For $remote_addr;
            proxy_set_header X-Forwarded-Proto $scheme;
        }

        error_page  404              /404.html;
        error_page  500 502 503 504  /500.html;
        location = /500.html {
            root   /app/kaminari_API/kaminari_API_rails/public;
        }
    }

    upstream app_server {
        server 127.0.0.1:3000;
    }
}

./kaminari_API/kaminari_API_rails/config/puma.rb

# Puma can serve each request in a thread from an internal thread pool.
# The `threads` method setting takes two numbers: a minimum and maximum.
# Any libraries that use thread pools should be configured to match
# the maximum value specified for Puma. Default is set to 5 threads for minimum
# and maximum; this matches the default thread size of Active Record.
#
threads_count = ENV.fetch("RAILS_MAX_THREADS") { 5 }
threads threads_count, threads_count

# Specifies the `port` that Puma will listen on to receive requests; default is 3000.
#
port        ENV.fetch("PORT") { 3000 }

# Specifies the `environment` that Puma will run in.
#
environment ENV.fetch("RAILS_ENV") { "development" }

# Specifies the number of `workers` to boot in clustered mode.
# Workers are forked webserver processes. If using threads and workers together
# the concurrency of the application would be max `threads` * `workers`.
# Workers do not work on JRuby or Windows (both of which do not support
# processes).
#
# workers ENV.fetch("WEB_CONCURRENCY") { 2 }

# Use the `preload_app!` method when specifying a `workers` number.
# This directive tells Puma to first boot the application and load code
# before forking the application. This takes advantage of Copy On Write
# process behavior so workers use less memory.
#
# preload_app!

# Allow puma to be restarted by `rails restart` command.
plugin :tmp_restart

試していること

nginxがrailsのpumaとうまく接続できていないのではないかと思い、調べてはいるものの、迷走しています。
どんなことでもいいので、何か回答をいただきたく。。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • t_obara

    2019/03/04 16:29

    リバースプロキシの設定(nginx.conf)は何を参考にされましたか?その点をご提示ください。

    キャンセル

  • Daimian

    2019/03/04 17:00

    コメントありがとうございます!!
    https://qiita.com/pipi_taro/items/5c627859cf2d38a66a3e
    を参考にさせていただいてます!

    キャンセル

  • Daimian

    2019/03/04 17:59

    さらに申し上げると、ログを確認しようと思ってnginxのコンテナに入っても、ログが出力されて来ません。。accessログも、errorログも・・

    キャンセル

回答 1

checkベストアンサー

0

以下の点をご確認ください。参照したページとも違っています。

nginx.conf


proxy_pass http://web;


proxy_pass http://app_server;

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/04 18:07

    ご回答ありがとうございます!修正しましたが、状況変わらずでした。。

    キャンセル

  • 2019/03/04 18:26

    今回の件を踏まえ、再度参考にした内容を見直してみてはいかがですか?
    また、修正後に再起動して確認しているのですよね?

    キャンセル

  • 2019/03/04 18:33

    ありがとうございます、修正後に再起動して確認しています!内容ももう一度確認しています!

    キャンセル

  • 2019/03/04 23:27 編集

    色々とご対応ありがとうございました!

    proxy_pass http://app_server;

    upstream app_server {
    server web:3000;
    }

    この2つの記述の追加・変更でうまく行きました。
    dockerコンテナ内で127.0.0.1のURIで探しても、コンテナ内しか探してもらえないみたいです。
    dockerネットワーク内であればhost名で名前解決ができるため、web:3000の記述が有効みたいです。

    【参考】
    https://serverfault.com/questions/895789/111-connection-refused-nginx-proxy-for-docker-containers

    解決に丸1日かかりましたがなんとか、お陰様で出来ました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る