質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.65%

nodeでローカルサーバーが作れない!npm installでnode-pre-gyp WARNが出てしまう

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 3,542

kumakuma112

score 17

Node.jsでローカルサーバー立てて、hyperupとかsassとか勉強してるのですが、
こないだ作った環境でつい先程まで動いてたローカルサーバーが急にエラーで動かなくなりました。

おかしいと思い、node_modulesを削除してnpm installで再インストールしたらみたことないエラーがでました。

MacBook-Pro:sample sampleuser$ npm install

> fsevents@1.2.7 install /Users/sampleuser/git/sample/node_modules/fsevents
> node install

node-pre-gyp WARN Using needle for node-pre-gyp https download
[fsevents] Success: "/Users/sampleuser/git/sample/node_modules/fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node" is installed via remote

> grpc@1.18.0 install /Users/sampleuser/git/sample/node_modules/grpc
> node-pre-gyp install --fallback-to-build --library=static_library

node-pre-gyp WARN Using needle for node-pre-gyp https download
[grpc] Success: "/Users/sampleuser/git/sample/node_modules/grpc/src/node/extension_binary/node-v64-darwin-x64-unknown/grpc_node.node" is installed via remote
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN sample@1.0.0 No repository field.
npm WARN sample@1.0.0 scripts['server'] should probably be scripts['start'].

added 1067 packages from 494 contributors and audited 10798 packages in 21.772s
found 1 low severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details

nodeのバーションは、10.6.0
npmは、6.1.0
pythonは、2.7.10

ド素人すぎて、わからず困ってます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

npm WARNが出てびっくりしたと思いますが、
npmのインストール時に表示されるWARNは単なるNoticeやInfomationと同レベルです。
「ファイル探したけどないやん、だったら用意しないといけないな」みたいな事しか書いてありません。

末尾のfound 1 low severity vulnerability
run npm audit fix to fix them, or npm audit for details
…を和訳すると、

1個のモジュールに脆弱性が含まれているので非推奨です。
npm auditを実行すれば詳細を画面に表示、その後npm audit fixを利用して取り除いてください。

勝手に取り除くと動かなくなる可能性があるので、作者に報告するくらいで良いと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.65%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る