質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Emacs

    157questions

    GNU Emacsと拡張性の高い、高性能なテキストエディタです。豊富なライブラリの導入により、統合開発環境やWebブラウザとしても機能させる事が可能です。

emacsを閉じる時にエラーが出る。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 247

akio77

score 6

Macに新しくemasを入れました。その際多分デフォルトのemacsは消去したと思います。ここまでは問題ないと思っていたのですが、emacsを終了するとエラーが発生します。これはなんなのでしょうか。

2019-02-15 23:51:52.792 Emacs-x86_64-10_10[4605:515900] Failed to initialize color list
 unarchiver: Error Domain=NSCocoaErrorDomain Code=4864 "*** -[NSKeyedUnarchiver
 _initForReadingFromData:error:throwLegacyExceptions:]: non-keyed archive cannot be
 decoded by NSKeyedUnarchiver" UserInfo={NSDebugDescription=*** -[NSKeyedUnarchiver
 _initForReadingFromData:error:throwLegacyExceptions:]: non-keyed archive cannot be
 decoded by NSKeyedUnarchiver}
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

これは https://teratail.com/questions/173706 と同じだと思います。

Emacsが廃止されたAPIを使用しているためですので、最新の開発版のEmacsと差し替えてみてください。修正されていると思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/16 12:43 編集

    回答本当にありがとうございます!指摘された通りやってみましたが。。。。
    https://emacsformacosx.com/buildsのサイトのpretestsのなかのEmacs-pretest-26.1.91-universal.dmgをダウンロードして今入ってるemacs と置き換えたのですが、同じエラーが出てしまいました。

    またこんなエラーも追加されました。
    Warning: arch-dependent data dir '/Users/build/workspace/Emacs-Multi-Build/label/yosemite/emacs-source/nextstep/Emacs.app/Contents/MacOS/libexec/': No such file or directory

    キャンセル

  • 2019/02/23 15:14 編集

    I have not macos and I am not quite sure that this issue might be caused by the emacs distributed for MacOS Mojave. Reported on emacs-devel ML: https://lists.gnu.org/archive/html/emacs-devel/2018-09/msg00900.html . And also discussing on: https://stackoverflow.com/questions/52521587/emacs-error-when-i-call-it-in-the-terminal . HTH

    キャンセル

  • 2019/02/23 16:56

    thank Stan_Dma
    ありがとうございました。無事解決しました。

    キャンセル

check解決した方法

0

Stan_Dmaさんが教えてくれたサイトで
解決方法
ここにも書いてある通り、
~/Library/Colors/Emacs.clr
このファイルを消去するだけで解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Emacs

    157questions

    GNU Emacsと拡張性の高い、高性能なテキストエディタです。豊富なライブラリの導入により、統合開発環境やWebブラウザとしても機能させる事が可能です。