質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.36%

  • Ruby

    8715questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8117questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MySQL

    6521questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

mysql2を指定するとエラーが起きます

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 64

honda_toru

score 4

gemfileをmysql2の指定で
gem 'mysql2', '0.5.2'では問題ないのですが
mysql2をgem 'mysql2', '0.3.18'と指定した場合に

$rails s実行すると以下の表示がされます
----------------省略----------------------------
2: from /Users//.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.4.0/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require'       1: from /Users//.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/activerecord-5.2.2/lib/active_record/connection_adapters/mysql2_adapter.rb:6:in <main>'
/Users//.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.1/lib/bundler/rubygems_integration.rb:408:in `block (2 levels) in replace_gem': Error loading the 'mysql2' Active Record adapter. Missing a gem it depends on? can't activate mysql2 (< 0.6.0, >= 0.4.4), already activated mysql2-0.3.18. Make sure all dependencies are added to Gemfile. (LoadError)

エラー文から'mysql2', '0.3.18'がmysql2 (< 0.6.0, >= 0.4.4)の範囲外が原因なのはわかりますが、herokuにアップする段階で'mysql2', '0.3.18'に指定する必要があります。
憶測ですが、rubyまたはrailsのバージョンが'mysql2', '0.3.18'に対応してないことが問題のような気がします。
$ rails -v
Rails 5.2.2
$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin17]
$ rbenv -v
rbenv 1.1.1

$rails _5.2.1_ new sample -d mysql

かなり長い期間ここでハマっております、解決策をご教示いただけないでしょうか?

以下は試したことです
$bundle update
$bundle update mysql2
$sudo bundle update
$bundle install

環境
macOS10.13.6

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

rbenvを使っている状態でbundleコマンドをsudoで呼び出すと~/.rbenvディレクトリ内部にroot権限を持つファイルができ、正常な動作が妨げられることがあります。

一度rbenvを完全にアンインストールしてから再インストールを行ってはどうでしょうか。

具体的な削除方法は公式のページを参照してください。
https://github.com/rbenv/rbenv#uninstalling-rbenv

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/12 23:41

    回答ありがとございます
    リンク先の手順に
    "Rubyバージョンを管理しているrbenvを無効にするには、単にあなたのシェルスタートアップ設定からrbenv init行を削除してください"とありますが具体的にどのようなコマンドを実行すれば良いのでしょうか?ご存知でしたらご教示お願いいたします。

    キャンセル

  • 2019/02/12 23:59

    一時的に無効にするのではなく "rm -rf `rbenv root`"で`rbenv`がインストールされたディレクトリを削除後に再インストールしてください。

    キャンセル

  • 2019/02/13 00:09

    リンク先のUninstalling rbenvの手順にシェルスタートアップ設定からrbenv init行を削除してから、rm -rf `rbenv root`を実行してくださいと記載があるのですが、rm -rf `rbenv root`から実行しても大丈夫なのでしょうか?

    キャンセル

  • 2019/02/13 00:56

    再インストール時にもう再度書くことになりますが、`/Users/username/.bashrc` か `/Users/username/.bash_profile` に eval "$(rbenv init -)" という記述があるはずなのでその行を消すことを指しています。もし`bash`以外のシェルを使っている場合はシェルのスタートアップ設定は別のファイルで行われるので、該当のファイル内の該当行を削除してください。

    キャンセル

  • 2019/02/13 07:00

    rbenvをアンインストールしてから再インストールできました。

    もう一度gemfileで 'mysql2', '0.3.18'を指定しようとしましたが
    やはり(< 0.6.0, >= 0.4.4)から外れるとエラーが起きるみたいです。
    bundleコマンドをsudoで呼び出してはいけないことや、アンインストールの手順など
    大変勉強になりました。ありがとうございます。

    キャンセル

同じタグがついた質問を見る

  • Ruby

    8715questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8117questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MySQL

    6521questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。