質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Emacs

    157questions

    GNU Emacsと拡張性の高い、高性能なテキストエディタです。豊富なライブラリの導入により、統合開発環境やWebブラウザとしても機能させる事が可能です。

Warning (php-indent): Indentation fails badly with mixed HTML and PHP. Look for an Emacs Lisp lib

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 145

ruei

score 222

Emacsでphpファイルを編集していると

Warning (php-indent): 
    Indentation fails badly with mixed HTML and PHP.
    Look for an Emacs Lisp library that supports "multiple
    major modes" like mumamo, mmm-mode or multi-mode.

というエラーがたまに出ます。

ネットで調べても、具体的な解決方法が見つかりません。

解決方法のわかる方がいらっしゃったらご教示ください。

Emacsのバージョンは以下の通りです。

emacs --version
GNU Emacs 23.4.1
Copyright (C) 2012 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

一つのファイルに様々なハイライトルール、インデントルールを混在させることは容易ではありません。そのワーニングはその実現のために複数のメジャーモードを有効にする方法を勧めるものです。

なお、Emacsが「枯れて」安定したエディタであることは私も同意しますが、流動性の高いフロントエンドのファイルや新しい言語のファイルを編集しようとした場合、古いEmacsでは障害になることがあります。
Emacs-23は package.el というパッケージマネージャも満足に動きませんし、そもそも最新のphp-modeはEmacs-23をサポートしていません。

Emacsをインストールできる環境にあるならば最新の安定版であるEmacs-26.1をインストールして php-mode.el や web-mode.el のようなパッケージを使用されることをおすすめします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Emacs

    157questions

    GNU Emacsと拡張性の高い、高性能なテキストエディタです。豊富なライブラリの導入により、統合開発環境やWebブラウザとしても機能させる事が可能です。