質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

Let'sEncryptの更新でエラーがでる

受付中

回答 3

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 2,767

score 20

AWSを使っています。
Let'sEncryptの更新のために

$sudo certbot-auto renew --force-renew --debug


とサーバ上で実行すると

pkg_resources.DistributionNotFound: The 'virtualenv==15.1.0' distribution was not found and is required by the application

のエラーがでました。そこでググった他の記事を参考に、

$sudo pip install virtualenv>=15.1.0


と打つと

pkg_resources.DistributionNotFound: The 'pip==9.0.3' distribution was not found and is required by the application


とエラーがでてきて、さらに詰まりました。
お詳しい方、助け舟をだしていただけないでしょうか。
よろしく願いします。

※追記
sudo付きでもpipとpip3コマンドは使えるようにしました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • kabao

    2019/02/03 14:38

    pipや、Python本体を複数インストールしていたりしますか?
    このあたりが参考になるかもしれません。
    http://www.stockdog.work/entry/2017/08/11/215000

    キャンセル

  • hichon

    2019/02/03 15:40 編集

    Amazon Linuxなら以下を参照
    https://community.letsencrypt.org/t/help-with-certbot-on-the-new-amazon-linux-2/

    キャンセル

回答 3

+2

私もAWSでLet's Encryptを更新しようとして同じエラーが出まして、

easy_install pip==9.0.3
easy_install virtualenv==15.1.0

で解決できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

pipのバージョンが9.0.3ではないということだと思うのですが、もし古いバージョンを使っているということであれば、

pip install --upgrade pip


でpip自体を更新して、その後virtualenvをインストールしてみてはどうでしょうか。


virtualenvのrelease historyを見ると、15.2.0付近でpip9.0.3を必要とするようになっているようです。
https://pypi.org/project/virtualenv/#history

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/11 10:02

    コピペミスってませんか?versionですよ?

    キャンセル

  • 2019/02/12 05:46

    もういちど試しましたがコピペはうまくできてます。
    [*****@ip-1*-0-0-*** ~]$ sudo pip --version
    [sudo] password for ****:
    Traceback (most recent call last):
    File "/usr/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3126, in <module>
    @_call_aside
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3110, in _call_aside
    f(*args, **kwargs)
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3139, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 581, in _build_master
    ws.require(__requires__)
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 898, in require
    needed = self.resolve(parse_requirements(requirements))
    File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 784, in resolve
    raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'pip==9.0.3' distribution was not found and is required by the application

    キャンセル

  • 2019/02/12 23:53

    なるほど。。。versionだけでそうなると、本格的に壊れてそうですね。
    自分ならPythonを全部1回消してインストールしなおしますね。
    Python 2系と3系両方入れているなら、両方消して、まず2.7だけ再インストールして試すかなと。

    キャンセル

+1

もうすでに壊れているようなので...
次やるときの参考になればと思います.

複数のpythonのバージョンをインストールできるpyenvの導入
python -m venv envでpythonの仮想環境を作成する

などをしてもしpythonでエラーが出ても,壊れてもいい仮想環境を作成してから,色々することをおすすめします.

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る