質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

cloud9のrailsの設定

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 579

score 16

やりたいこと

cloud9上でrailsでミニサービス的なもの(ユーザ管理機能やログイン機能)を作りたい。

わからないこと

最初の環境構築??でなにをすればよいのかわかりません。(入力しなければならないコマンド等)

試したこと

サイトやテキストを見ながら

gem install rails
gem install bundler


を入力した後に

rails new "アプリケーション名" -d mysql


を入力したところ

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
An error occurred while installing mysql2 (0.5.2), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.5.2' --source 'https://rubygems.org/'` succeeds before bundling.
bundler: command not found: spring
Install missing gem executables with `bundle install`


のようなエラーが見受けられました。

知りたいこと

これらのエラーはどうすれば解決できますでしょうか??
そもそも、最初のコマンドが間違っているのでしょうか??
よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2019/02/02 09:38

    たとえば GO RAILS では Ubuntu, Mac, Windows での Rails のセットアップ方法を教えてくれる (Ubuntu: https://gorails.com/setup/ubuntu/18.10 ) のですが、説明にある通り色々インストールする必要がありそうです。(特に「sudo apt-get install git-core curl zlib1g-dev build-essential...」の部分)

    OS 側にインストールする必要がある様々なパッケージは導入済みでしょうか?

    キャンセル

  • daaaichifu

    2019/02/02 13:52

    ありがとうございます🙇‍♂️

    リンクページを参照して、やってみます!

    キャンセル

回答 1

checkベストアンサー

+1

エラーが途切れ途切れなのではっきりしたことは言えませんが、mysql2というgemがインストールされていないためのエラーは出ているようですね。

以下を一行ずつ実行してください。

$ sudo yum -y install mysql-devel
$ gem install mysql2

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る