質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Python

    11683questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Python 3.x

    9776questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • pip

    234questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

pip3のインストール先を変えたい

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 767

Ykkykk

score 78

pip3を使用してdrfapikeyというモジュールをインストールしたのですが、ModuleNotFoundErrorが出ています。

sudo pip3 install drfapikey


上記コマンドを実行すると、

The directory '/home/●●●/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/●●●/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.


上記のメッセージが出ているのですが、インストール自体はできています。
これまでにpip3を使ってインストールしたモジュールなどは、

/home/●●●/.local/lib/python3.6/site-packages/


というディレクトリに入っているのですが、今回のインストール先を確認したところ、

/usr/local/lib/python3.6/dist-packages


というディレクトリに入っておりました。
コンソール上でpython3と打ち、インタプリタを起動すると、

import drfapikey

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'drfapikey'


となってしまいます。

PYTHONPATHが通っていない、などの原因があるようなのですが、これまでにsudo pip3 installしてきたものは問題なく使えていました。

上記のようなエラーが出る原因は何なのでしょうか?
また、どのようにすれば使えるようになるのでしょうか?
ご教示いただけますと幸いです。よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

エラーメッセージを見る限り、権限のないディレクトリにアクセスしているようです。

sudoした状態なら、問題なく動作しませんか?

sudo pip3でインストールしたものは、/usr/local/lib~へ
pip3でインストールしたものは、/home/●●●/.local/lib~へ

インストールされているのではないでしょうか?

追記

importできない理由がわかりました。

このライブラリは、Djangoで利用する、Rest framework api keyですね。

importして利用するものではなく、
Djangoのsettings.pyにある、INSTALLED_APPSに追加して利用するようです。

詳しくは、ライブラリのリファレンスをご参照のほど。
drfapikey

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/31 12:51

    ご回答いただきありがとうございます。
    インストール自体はできているようなのですが、質問で記載しているように、インタプリタでインポートしようとするとエラーが出ている状態です…。
    一応、sudo pip3 uninstall で一度アンインストールしてから、pip3 install をしてみたのですが、sudoをつけていないと、許可がないというエラーが出てインストール自体ができませんでした。

    キャンセル

  • 2019/01/31 12:55

    sudo python3でインタープリターを立ち上げてもダメでしょうか?

    キャンセル

  • 2019/01/31 12:56

    python -Vを実行すると、結果はどうなりますか?
    which pythonの結果もわかると、良いかもです。

    キャンセル

  • 2019/01/31 13:10

    sudo python3で立ち上げても同じエラーが出てしまいました。。
    which pythonの結果は、
    /usr/bin/python
    でした。
    which python3では、
    /usr/bin/python3
    でした。

    キャンセル

  • 2019/01/31 13:22

    python -Vの結果は、
    Python 2.7.15rc1
    でした。
    python3 -Vの結果は、
    Python 3.6.7
    でした。

    キャンセル

  • 2019/01/31 13:28

    背景がわからないので、なんとも言えませんが・・・

    sudo -H pip3 install drfapikey

    でインストールするとどうでしょうか?

    キャンセル

  • 2019/01/31 13:35

    一度アンインストールして、-Hをつけてインストールしてみたところ、インストール自体はできているのですが、やはり先ほどまでと同じディレクトリに収まっており、インタプリタ上ではインポートできない状態でした…。
    Pythonの問題なのでしょうか?

    キャンセル

  • 2019/01/31 13:51

    なんでしょうねぇ・・・

    pip3 show pipの実行結果はどうでしょう?

    キャンセル

  • 2019/01/31 14:09

    Name: pip
    Version: 19.0.1
    Summary: The PyPA recommended tool for installing Python packages.
    Home-page: https://pip.pypa.io/
    Author: The pip developers
    Author-email: pypa-dev@groups.google.com
    License: MIT
    Location: /usr/local/lib/python3.6/dist-packages
    Requires:
    Required-by:

    このようになっていました。

    キャンセル

  • 2019/01/31 14:42

    Due to your operation, not Python. It may be reduced your difficulty when you delete all the contents of the directory called /home/foo/.cache/pip by root using command like 'rm -fr', if there is no problem.

    キャンセル

  • 2019/01/31 15:33

    Thanks for your comment.
    I deleted the directory but there is the same error.

    キャンセル

  • 2019/01/31 15:51

    Home下のディレクトリに入る理由が全くわからないのですが、

    pip3 install drfapikey --user

    だとどうでしょう?

    キャンセル

  • 2019/01/31 15:56

    pip showの結果が
    /home/●●●/.local/lib/python3.6/site-packages
    に変わりました!
    ですが、インタプリタではやはりモジュールエラーが出てインポートできないです。。

    キャンセル

  • 2019/01/31 17:54

    ちなみに・・・
    virtualenvやvenvは利用していないですよね?

    キャンセル

  • 2019/02/01 10:59

    使用していないです。。。

    キャンセル

  • 2019/02/01 17:53

    回答に追記しましたので、ご確認を。

    キャンセル

  • 2019/02/04 10:14

    ご追記くださりありがとうございます。
    importするものではないということなのですね。
    本当にありがとうございました。

    キャンセル

同じタグがついた質問を見る

  • Python

    11683questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Python 3.x

    9776questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • pip

    234questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。