質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.48%

名前に_が二つ以上あると403

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,228

score 6817

ちょっとエラーの原因が意味不明すぎてさっぱり原因がわからず困っています

Wordpressで管理画面の記事投稿の際に
カスタムフィールドの名前に_が二つ以上あると403になります

<input type="text" name="post_meta[class_price_info][value][0][name][]" value="" tabindex="5" class="text-name" id="text-name_5">

このclass_price_infoのところが引っかかってるようなのです
classprice_infoとかにすると動きます

他の投稿タイプでも同じでした

_について_が頭についていた場合には管理者権限がないと更新できない
という処理は書きましたが、当該箇所を除去しても同じでした

カスタムフィールド周りの処理は複雑になってるとはいっても
名前の_でexplodeしてどうこうするような
処理を書いたような覚えはありません


ローカルのMAMPでは問題なく動いてます
サーバーにあげると投稿時に403が返ります

_が二つ以上あるということは
何か意味を持つことなのでしょうか?

サーバーはhetemlです

よろしくお願いします
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

+1

すいません、早速自己解決しました

あれこれ試してみた結果、原因は_ではなく
classという名前を含んでいることのようでした
_で区切ったときにclassというのがあるだけでダメらしいです
前でも途中でも後ろでもダメっぽいです

別の投稿タイプでも同様にclassというのが名前の一部にあるので
同じくこれが原因であろうと思います

これを引っ掛けているのがWordpressなのかサーバなのか
Wordpressならなんでローカルでは動いてるのか
そのあたりまだ解明していませんが
とりあえず予約語かセキュリティの関係で
classという単語が引っかかっているということが判明しました

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

私も共用サーバとVPS両方で検証しましたが、「_」が2つあっても問題なく動作しているようでした。

サーバ環境に依存しているかもしれません。
エラーログとWAFのログに何か出ていませんか?

ヘテムルはソフトウェアWAFがデフォルトで有効になっていたと思います。シグネチャを個別に無効にするか、一時的にWAFそのものを無効にして再度ためしてみるといかがでしょうか。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.48%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る