質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.08%

Jupyter notebook In[*]の解決法 (kernel -> restartではNG)

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,786

tatsunaru

score 13

Jupyter notebook でIn[*]が表示されコマンド実行できない

Pythonでのデータ分析についての学習を始めようと思いJupyter notebookの環境構築しました。起動まではできましたがshift+Enterでコマンドを実行しようとしても、表題の通り実行できません。kernelはPython3です。
他の質問であったKernel -> restartも試みましたが効果がみられませんでした。

ターミナルを見るとどうもセッション関連でループが発生しているようなのですが、これらのエラーメッセージと思われる内容をみても記載されているファイルを直接触ったことはなく、手詰まりの状態です。

環境構築は以下に沿って行いました。
①参考した書籍が引用していた以下サイトの手順
https://github.com/ghmagazine/python_stat_sample/blob/master/tutorial/env_const/macos.md

②上記とは別にAnaconda仮想環境を作成し以下を実行
(上記書籍がJupyterを少しは使ったことある人向けっぽい印象を受けたのでより、初級者向けの本からやり直し。)
$conda install -y jupyter==1.0.0
$conda install -y notebook==5.0.0
$conda install -y pandas==0.19.2
$conda install -y bokeh==0.12.5
$conda install -y matplotlib==2.0.1

上記以外は特段変わったことはしていないです。
この環境構築でanacondaをインストールする前にPythonの勉強のためにPython 3.7.0をインストールしていたくらいです。

発生している問題・エラーメッセージ

JupyterでPython3でのnotebook作成を選択すると、ターミナル上で以下MSGが繰り返し表示されます。

[I 10:49:03.989 NotebookApp] Adapting to protocol v5.1 for kernel df33c46d-af37-452f-bacf-e3507dcbc586
[E 10:49:03.990 NotebookApp] Uncaught exception GET /api/kernels/df33c46d-af37-452f-bacf-e3507dcbc586/channels?session_id=D973AA3A5EC54C8FB02C0EBDEB281C40 (::1)
    HTTPServerRequest(protocol='http', host='localhost:8888', method='GET', uri='/api/kernels/df33c46d-af37-452f-bacf-e3507dcbc586/channels?session_id=D973AA3A5EC54C8FB02C0EBDEB281C40', version='HTTP/1.1', remote_ip='::1')
    Traceback (most recent call last):
      File "/Users/username/.pyenv/versions/anaconda3-5.2.0/envs/jupyter-env/lib/python3.6/site-packages/tornado/websocket.py", line 546, in _run_callback
        result = callback(*args, **kwargs)
      File "/Users/username/.pyenv/versions/anaconda3-5.2.0/envs/jupyter-env/lib/python3.6/site-packages/notebook/services/kernels/handlers.py", line 262, in open
        super(ZMQChannelsHandler, self).open()
      File "/Users/username/.pyenv/versions/anaconda3-5.2.0/envs/jupyter-env/lib/python3.6/site-packages/notebook/base/zmqhandlers.py", line 176, in open
        self.send_ping, self.ping_interval, io_loop=loop,
    TypeError: __init__() got an unexpected keyword argument 'io_loop'

補足情報(FW/ツールのバージョンなど)

PC環境
MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports)
version 10.14.2
FireWall設定あり(設定切ってみましたが挙動変わらず)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Tornado Web Serverというパッケージの問題のようです。
https://www.tornadoweb.org/en/stable/

python3.5環境で同じ問題に遭遇した人がいます。tornado を4.5.3 にバージョンダウンすることで解決。
http://thinkami.hatenablog.com/entry/2018/08/04/102850

参考情報:
私の環境(python 3.7)では、condaは使わずパッケージをインストールしています。問題は出ていません。

Mac Darwin Kernel Version 17.7.0
python 3.7.1_0

$ sudo port installed | grep py37 | grep active | grep -i tornado
  py37-tornado @5.1.1_0 (active)

$ sudo port installed | grep py37 | grep active | grep -i jupy
  py37-jupyter @1.0.0_1 (active)
  py37-jupyter_client @5.2.3_1 (active)
  py37-jupyter_console @5.2.0_0 (active)
  py37-jupyter_core @4.4.0_0 (active)

fedora29 4.19.10-300.fc29.x86_64
python 3.7.1

$ pip3 -v list | grep tornado
tornado                           5.0.2      /usr/lib64/python3.7/site-packages  

$ pip3 -v list | grep -i jupy
JupyROOT                          6.14.8     /usr/lib64/python3.7/site-packages                
jupyter                           1.0.0      /usr/local/lib/python3.7/site-packages   pip      
jupyter-client                    5.2.2      /usr/local/lib/python3.7/site-packages   pip      
jupyter-console                   5.2.0      /usr/local/lib/python3.7/site-packages   pip      
jupyter-contrib-core              0.3.3      /usr/local/lib/python3.7/site-packages   pip      
jupyter-contrib-nbextensions      0.5.0      /usr/local/lib/python3.7/site-packages   pip      
jupyter-core                      4.4.0      /usr/lib/python3.7/site-packages                  
jupyter-highlight-selected-word   0.2.0      /usr/local/lib/python3.7/site-packages   pip      
jupyter-latex-envs                1.4.6      /usr/local/lib/python3.7/site-packages            
jupyter-nbextensions-configurator 0.4.0      /usr/local/lib/python3.7/site-packages   pip

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/04 08:47

    amdahlslaw様

    ご返信遅くなり恐縮です。
    ご提示いただいた回答で無事解決いたしました。各種リンクや参考情報などご丁寧な回答ありがとうございました。

    キャンセル

  • 2019/01/04 19:07

    問題が解決してよかったです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.08%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る