質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.36%

ライブラリ読み込みエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,896

papa

score 12

前提・実現したいこと

現在deeplearningを勉強しています。ubuntu上でdeeplearningの環境構築をしているのですが、pythonを対話モードでtflearnをインポート出来ているにもかかわらず、コードにimport文を書いて実行すると以下のようなエラーが発生してしまいます。

### 発生している問題・エラーメッセージ

ImportError                           Traceback (most recent call last)

~/anaconda3/lib/python3.5/site-packages/tflearn/layers/recurrent.py in <module>()
8 try:
---->9       from tensorflow.python.ops.rnn import rnn cell impl as rnn cell, dynamic rnamic rnn as brnn
10     core rnn cell = rnn cell

ImportError: cannot import name 'rnn cell impl'

During handling of the above exception, another exception occured:

ImportError                       Traceback (most recent call last)
<ipython-input-2-761bfc07b3ed> in <module>()
----> 1 import tflearn
2 import tflearn.datasets.mnist as mnist

4 from matplotlib import pyplot as plt
5 from matplotlib import cm

~/anaconda3/lib/python3.5/site-packages/tflearn/  init   .py in  <module>() 
19
20 # Predefined ops
---->21 from . layers import normalization
22  from . import activations

~/anaconda3/lib/python3.5/site-packages/tflearn/layers/  init   .py in  <module>()  
9 from . normalization import batch normalization, local response normalization 
10 from . estimator import regression
----> 11 from .recurrent import lstm, gru, simple rnn, bidirectional rnn, ¥ 
12       BasicRNNCell, BasicLSTMCell, GRUCell
13 from.embedding ops import embedding

~/anaconda3/lib/python3.5/site-packages/tflearn/layers/recurrent.py in <module>() 
11 except:
12      #Fix for TF 1.1.0 and under 
---->13   from tensorflow.contrib.rnn.python.ops.core rnn import static rnn as  rnn, stat
14      from tensorflow.python.ops.rnn import rnn cell impl as rnn cell, dynamic rnn 
15      from tensorflow.contrib.rnn.python.ops import core rnn cell

Import Error: No module named 'tensorflow.contrib.rnn.python.ops.core rnn'

python
ソースコード

import tflearn
import tflearn.datasets.mnist as mnist

from matplotlib import pyplot as plt
from matplotlib import cm
import numpy as np

試したこと

pip install h5py 

python3.7から3.6にグレードダウン(一度python3.5にしてしまい、そのあと3.6にしました)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

python3.7から3.6にグレードダウン(一度python3.5にしてしまい、そのあと3.6にしました) 

3.7 と 3.6 と 3.5 が入っていて、
pythonの実行はどのバージョンで、

pip install h5py  

どのバージョンのpipを実行してるんでしょうか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/24 14:03

    一度anacondaを削除し、過去のアーカイブからpython3.6板で環境高知木をした結果、エラーが出なくなりました。しかし、tensorflowをインポートすると、future warningがでてきてしまいます。

    キャンセル

  • 2018/12/24 14:12

    ワーニングはあくまで警告なので、実行には支障はないはずです

    それはともあれ、
    「tensorflow future warning」でぐぐるといろいろでてきますねー

    キャンセル

  • 2018/12/24 15:54

    pip install h5py==2.8.0rc1を打ち込んだらエラーが出なくなりました。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る