質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

Pillowをインストールできてもjpgの読み込みができない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 5,071

score 10

前提・実現したいこと

自分で撮影した画像を用いてkerasでCNNする前段階として、とりあえず画像を1枚読み込みたい。

発生している問題・エラーメッセージ

---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-10-40216d0f648d> in <module>
      1 import keras
      2 from keras.preprocessing.image import array_to_img, img_to_array, load_img
----> 3 temp_img = load_img('RIMG6767.JPG')

~\Anaconda3\envs\tensorflow\lib\site-packages\keras_preprocessing\image.py in load_img(path, grayscale, color_mode, target_size, interpolation)
    494         color_mode = 'grayscale'
    495     if pil_image is None:
--> 496         raise ImportError('Could not import PIL.Image. '
    497                           'The use of `array_to_img` requires PIL.')
    498     img = pil_image.open(path)

ImportError: Could not import PIL.Image. The use of `array_to_img` requires PIL.

該当のソースコード

import keras
from keras.preprocessing.image import array_to_img, img_to_array, load_img
temp_img = load_img('RIMG6767.JPG')

試したこと

PILをnavigator上でインストールされていないことを確認してから、navigator上でPillowをインストールして成功。
しかし、エラーは変わらず。
そこで\Anaconda3\envs\tensorflow\lib\site-packagesをエクスプローラーで開いてみると、\PILのファイルと\Pillow-5.3.0-py3.6.egg-infoというファイルを確認。
PILなんてインストールしてないのに…と思い、ターミナルを開いて
pip uninstall PIL を打つとPILはインストールされていませんと出る。
そのままpip uninstal Pillow をしてすべてのPillowをuninstall。
再度navigatorからPillowをダウンロード。

補足情報(FW/ツールのバージョンなど)

Win 10, anaconda navigatorを使ってrootのほかにtensorflowという環境を作ってそのtensorflowという環境で作業を行っています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • tiitoi

    2018/12/22 03:52

    使おうとしている環境に pillow が入っていないのではないでしょうか?Anaconda を使う際は今どの仮想環境で作業しているのか意識してください。環境ごとにパッケージは別に管理されてるので、ある環境にインストールしても別の環境では使えません。

    キャンセル

  • MasatakaSeki

    2018/12/23 04:33

    回答ありがとうございます。
    環境は意識して使用いていたつもりですが、PCからすべてPillowとPILというファイルを削除して(baseとtensorfloewという環境2つから削除)再度Pillowをtensorflow環境のみにインストールしたら問題のエラーが表示されなくなりました。
    その際に --no-cache-dir をつけてanacondaではなくコンソールでインストールしました。
    初心者なもので理由はわかりませんが、キャッシュが残っていたのかもしれません。(PILと
    Pillowは同時に存在しては使えないとどこかの記事で読みました)
    原因不明とはいえ、自己解決してしましましたが、早速の回答ありがとうございました。

    キャンセル

回答 1

check解決した方法

0

--no-cache-dirでキャッシュを削除してインストールしたら解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る