質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.45%

  • ImageMagick

    115questions

    ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。

ImageMagick 7 をMac OS からアンインストールしたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 570
退会済みユーザー

退会済みユーザー

本来の目的 

rmagickの導入

$ gem install rmagick

エラーになる

Building native extensions. This could take a while...
ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.

    current directory: /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rmagick-2.16.0/ext/RMagick
/Users/名前/.rbenv/versions/2.5.1/bin/ruby -r ./siteconf20181219-13129-kplq5y.rb extconf.rb
checking for clang... yes
checking for Magick-config... no
checking for pkg-config... yes
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
checking for outdated ImageMagick version (<= 6.4.9)... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/名前/.rbenv/versions/2.5.1/bin/$(RUBY_BASE_NAME)

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/x86_64-darwin-17/2.5.0-static/rmagick-2.16.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rmagick-2.16.0 for inspection.
Results logged to /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/x86_64-darwin-17/2.5.0-static/rmagick-2.16.0/gem_make.out

リンク内容
上記の記事を参考。

ImageMagick 7 をアンインストールしたい

ターミナル

mba:アプリケーション名 名前$ brew uninstall imagemagick


エラー

Error: No such keg: /usr/local/Cellar/imagemagick

自分でやっちまったと思ったこと(直接的な原因じゃないかもしれませんが、一応書いておきます)

RMagick をインストールできたと思って
Gemfile

gem 'rmagick'

ターミナル

$ bundle install

をやってしまいました。

投稿したらこんな感じのエラーが出てきてしまいました。
イメージ説明

お手数ですがよろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • kazto

    2018/12/19 13:09

    「gem install rmagickを実行すること」と、「Gemfileに"gem 'rmagick' "を記載してbundle installを実行すること」は、同じ行為です。
    また、「brew uninstall imagemagick」時のエラーの内容はimagemagickのインストール先に実体が無い、と言っています。手動で/usr/local/Cellar/imagemagickを削除などしましたでしょうか。
    さて、ご質問者様の最終的な目的は、「rmagickを使えるようになること」でよろしいでしょうか。

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2018/12/19 13:18

    コメントありがとうございます。
    そうなんですね。次からの質問に反映されます。
    削除はしていないと思います。(ターミナルはブログなどに書かれていたコードをコピペしましたが、当初出ていたエラーコードと同じですので大丈夫だと思います)

    そうです!使いたいです!

    ちなみに全然意味のないことかもしれないんですが
    $ convert -versionをしたら
    Version: ImageMagick 6.9.10-14 Q16 x86_64 2018-10-25と出ました。

    キャンセル

回答 1

checkベストアンサー

+1

以下の手順でインストールできます。

  1. brew install imagemagick@6 とバージョン6を指定してインストールする
  2. PKG_CONFIG_PATH=/usr/local/opt/imagemagick@6/lib/pkgconfig gem install rmagick でインストールする

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/19 13:54

    回答ありがとうございます!途中までいい感じにできていたんですが、2でエラーになってしまいました。

    mba:mimi 名前$ brew install imagemagick@6
    Warning: imagemagick@6 6.9.10-14 is already installed and up-to-date
    To reinstall 6.9.10-14, run `brew reinstall imagemagick@6`
    mba:mimi 名前$ PKG_CONFIG_PATH=/usr/local/opt/imagemagick@6/lib/pkgconfig gem install rmagick
    ERROR: While executing gem ... (Errno::EACCES)
    Permission denied @ rb_sysopen - /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rmagick-2.16.0/.editorconfig
    mba:mimi 名前$

    となりました。

    キャンセル

  • 2018/12/19 14:28

    あー、やっぱりもう一個のご質問の方でやらかしてるのが影響しましたね。。。
    sudoつきでbundle installしてしまって、gemの管理ファイルがroot権限で作られてしまい、一般権限でファイルを作れなくなっています。

    `sudo chown -R 名前:staff /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems`
    で所有者を元に戻して、再度gem installしてみてください。

    キャンセル

  • 2018/12/19 14:37

    やらかしを見つけて頂いてありがとうございます。
    gem installってkaztoさんが最初回答してくれたコマンドですか。

    それとも、Gemfileにgem 'rmagick'を追加してbundle installのことですか。

    キャンセル

  • 2018/12/19 14:55

    gem install rmagickをしてみました!

    結果です。
    mba:mimi 名前$ gem install rmagick
    Building native extensions. This could take a while...
    ERROR: While executing gem ... (Errno::EACCES)
    Permission denied @ rb_sysopen - /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/x86_64-darwin-17/2.5.0-static/rmagick-2.16.0/gem_make.out

    キャンセル

  • 2018/12/19 20:09

    1) gem install
    私が提示しました、PKG_CONFIG_PATH から始まる長いコマンドの方です。

    2) エラーについて
    先ほどと同様アクセス権が無いエラーなので
    `sudo chown -R 名前:staff /Users/名前/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/`
    を実行してください。

    キャンセル

  • 2018/12/19 21:37

    $ PKG_CONFIG_PATH=/usr/local/opt/imagemagick@6/lib/pkgconfig gem install rmagick
    Building native extensions. This could take a while...
    Successfully installed rmagick-2.16.0
    Parsing documentation for rmagick-2.16.0
    Done installing documentation for rmagick after 1 seconds
    1 gem installed

    と出ました。rmagickの導入はできてますか。

    キャンセル

  • 2018/12/20 08:22

    > Successfully installed
    ʕ•̀ω•́ʔ✧

    キャンセル

  • 2018/12/20 12:23

    kaztoさん、ありがとうございました(嬉)
    ただ、ブラウザで投稿してみたらできませんでした。(大泣き)

    キャンセル

  • 2018/12/20 12:39

    もう一度再起動かけたらできました!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.45%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • ImageMagick

    115questions

    ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。