質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

初心者です。 javax.servlet.annotation.WebServlet がインポートできません。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 16K+

YugoOgura

score 12

最近、javaを学び始めたものです。初歩的な質問かもしれませんが、よろしくお願いします。

Eclipseを使ってサーブレットクラスを作成しようと思ったのですが、
「javax.servlet.annotation.WebServlet」をインポートしようと思っても、
「インポートされた javax.servlet.annotation は見つかりません」とエラーがでます。
参考にしている本を見ても、解決方法がのっておらず、困っています。
どなたか原因を教えて下さい。お願いします。

追記
使用しているアプリケーションサーバは、Apache Tomcatv7.0.xです。

どのようにしてサーブレットクラスを作成したかというと、
ファイルメニューから、「動的プロジェクト」を作成。
そのプロジェクトを、ローカルホストのTomcat7(Java7)サーバーに追加。
そして、そのプロジェクトの中にサーブレットクラスを新規作成しました。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • argius

    2015/09/18 23:05

    Eclipseで新規プロジェクトなどでプロジェクトを作成したと思いますが、これの種類によって操作が変わってきます。どのように新規プロジェクトを作成したかを教えてください。

    キャンセル

  • YugoOgura

    2015/09/18 23:21

    ありがとうございます。
    詳しく書きました。

    キャンセル

回答 3

checkベストアンサー

+3

javax.servlet.annotation.WebServletServlet 3.0でないと使えないようです。

Eclipseでどのようにプロジェクトを作っているのかを具体的に教えてください。


(追記)

動的Webモジュールを作成するときに、そのバージョンが3.0になっていればServlet3.0になっているはずです。
もう一度新規プロジェクトを実行してみて、ウィザード画面の「動的Webモジュール バージョン」という項目を見てみてください。
3.0が選択出来ない場合、Eclipseのバージョンが古い可能性もあります。その場合は新しいEclipseを使った方が良いです。

あとから変更するには、
プロジェクトのプロパティーを開き、プロジェクト・ファセットという設定を探します。
その中に「動的Webモジュール」という項目がありますので、それを3.0に変更すればServlet3.0になります。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/19 23:03

    確かに、3.0ではなく、2.5が選択されていました!ここが変更できればいいのですね!
    僕が使っているEclipseは,「Eclipse 4.5 Mars Pleiades All in One」です。
    これで選べるのが今のところServlet2.5までなのですが、これでは新しくないのでしょうか?

    キャンセル

  • 2015/09/19 23:49

    Apache Tomcat7.0が選択されている(らしい)というお話しでしたので、Eclipseが古い可能性を疑いました。
    Eclipse 4.5でしたら最新ですね。

    解決されたようですので、自己解決でも構いません、質問をクローズしていだだけると助かります。

    キャンセル

0

javax.servlet.annotation.WebServletというアノテーションを含んだservlet-api.jarがクラスパスにないと思われます。このアノテーションはServlet APIのv3.0に追加されたものなので、結構新しいです。

参考にされている書籍が解説されているのは、Servlet API v3.0を対象にしている書籍なのでしょうか?その辺りが異なると、設定方法も違うことがよくあります。できるだけ書籍に書かれている手順で環境を作り、バージョンに合わせることをオススメします。

参考: Webアプリケーションの基礎 Servlet編

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/18 22:58

    回答ありがとうございます。
    参考にしている書籍は、Servlet APIv3.0を対象にしており、その本の通りにやると、@WebServletアノテーションも自動で作成されるはずなのですが...。
    本と同じ手順でやったつもりなのです...。

    キャンセル

0

arguisさんからご指摘があった、プロジェクト・ファセットの動的Webモジュールの項目で、ランタイム(R)の項目を見たら、Tomcat6が選んであり、それをTmcat7に変更したら、Servlet3.0を選ぶことができ、すべてうまくいきました!!
使用しているサーバーがTomcat7でも、それ以外のところでtomcat6を選んでいたのがいけなかったみたいです。
お騒がせしました。回答してくださったかたがた、ありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる