質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.87%

phpとpostgreSQLが接続できません。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 924

mango

score 11

目標

postgreSQLをphpと接続させて使えるようにしたいです。

問題点

php-pgsqlをインストールしようとするとエラーが発生します。
知識不足のため原因がわからないです。
教えていただけると幸いです。

[vagrant@localhost ***]$ sudo yum -y --enablerepo=remi-php54 install php-pgsql php-mbstring
読み込んだプラグイン:fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp-srv2.kddilabs.jp
 * epel: ftp.riken.jp
 * extras: ftp.riken.jp
 * remi-php54: ftp.riken.jp
 * remi-safe: ftp.riken.jp
 * updates: ftp.riken.jp
remi-php54                                               | 3.0 kB     00:00
remi-php54/primary_db                                      | 219 kB   00:00
一致したパッケージ php-mbstring-5.4.45-16.el7.remi.x86_64 はすでにインストールされています。更新を確認しています。
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ php-pgsql.x86_64 0:5.4.45-16.el7.remi を インストール
--> 依存性の処理をしています: php-pdo(x86-64) = 5.4.45-16.el7.remi のパッケージ: php-pgsql-5.4.45-16.el7.remi.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-pgsql-5.4.45-16.el7.remi.x86_64 (remi-php54)
             要求: php-pdo(x86-64) = 5.4.45-16.el7.remi
            インストール: php-pdo-7.1.24-1.el7.remi.x86_64 (@remi-php71)
                php-pdo(x86-64) = 7.1.24-1.el7.remi
            利用可能: php-pdo-5.4.16-46.el7.x86_64 (base)
                php-pdo(x86-64) = 5.4.16-46.el7
            利用可能: php-pdo-5.4.45-15.el7.remi.x86_64 (remi-php54)
                php-pdo(x86-64) = 5.4.45-15.el7.remi
            利用可能: php-pdo-5.4.45-16.el7.remi.x86_64 (remi-php54)
                php-pdo(x86-64) = 5.4.45-16.el7.remi
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest

環境

CentOs7
php 7.1.24

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

PHPのバージョンが混在しています。異なるバージョンのパッケージをアンインストールしてバージョンを統一しましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

checkベストアンサー

0

remi's repositoryはremi-php54とremi-php71のどちらも使えるようになっていませんか?
remi-php71への依存性を排除しないといけない気がします。

っていうか、php5.4を使うのは、
何か古いシステムの保守目的ですか?

それとも、php7.1に移行しようとして失敗しているクチですか?
remi-php54系パッケージを全部削除したあと、
remi-php54系リポジトリを使えないようにして、
remi-php71リポジトリを常に使えるようにしてから
php環境再構築、
って流れのような気がする。

あんちょこ:
yumコマンド覚書き - Qiita
【初心者でもわかる】yumコマンドの使い方とリポジトリの追加方法

もしやと思って検索したら、php複数入れられた。
そりゃそうか。
Yum で複数バージョンの PHP を共存させる - Qiita

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.87%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる