質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.64%

AndroidStudioのProjectStructureについて

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,170

jin007

score 20

実現したいこと

ブレイクポイントを貼って、変数の中身をデバッグしてログに出して確認する。

実施したこと

1:Gitに存在しているソースをインポート。
2:以下エラーが出る。

Gradle sync failed: Unsupported method: BaseConfig.getApplicationIdSuffix().
The version of Gradle you connect to does not support that method.
To resolve the problem you can change/upgrade the target version of Gradle you connect to.
Alternatively, you can ignore this exception and read other information from the model.
Consult IDE log for more details (Help | Show Log) (28 s 738 ms)

このサイトを参考にして、
●変更前
初期設定

●変更後
変更後設定
→4.1は上記サイトの数字を拝借しました。
→3.2はダウンロードしてきたバージョンの数字を入れました。

3:以下のエラー発生

Gradle sync failed: Could not find com.android.tools.build:gradle:3.2.
Searched in the following locations:
https://jcenter.bintray.com/com/android/tools/build/gradle/3.2/gradle-3.2.pom
https://jcenter.bintray.com/com/android/tools/build/gradle/3.2/gradle-3.2.jar
Required by:
project :
Consult IDE log for more details (Help | Show Log) (3 s 29 ms)

設定を変更したことが原因なのはわかっているのですが、ここからの解決方法がわからないのでアドバイスのほどよろしくお願いいたします。

追加

「17:10追加」
*画像1
AndroidStudio

「17:35追加」
*画像2
イメージ説明

*追加1

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        jcenter()
        google()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2'
    }
}

allprojects {
    repositories {
        jcenter()
        google()
    }
}


を以下のように変更しました。

buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}

「18:20追加分」
*画像3イメージ説明
3.2.1

*画像4
ProjectStructure

「18:50追加分」
*画像5
SDKPlatforms

*画像6
SDKTools

*画像7
SDKUpdateSites

「19:15追加分」
warning出てた

「19:37追加分」
*追加2

dependencies {
    compile project(':bluetoothspp')
}


を以下のように変更。

dependencies {
    implementation project(':bluetoothspp')
}

*追加3

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
//    testCompile 'junit:junit:4.12'
//    compile 'com.android.support:appcompat-v7:23.1.1'
}


を以下のように変更。

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
//    testCompile 'junit:junit:4.12'
//    compile 'com.android.support:appcompat-v7:23.1.1'
}

他に、Update Build Tools version and sync projectを実行

*画像8
コード変更


●12/12
「11:00追加分」
未インストール

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Gradle versionとして指定できるバージョンは、Android Plugin versionによって制約があります。Android Plugin versionが3.1以上の場合、Gradle versionには4.4以上を指定する必要があります。

Android Gradle plugin release notes

Android Plugin versionの最新版は、Android Studioのバージョンと常に連動します。メニューのHelp→AboutでAndroid Studioのバージョンを調べてみてください。今日現在の最新版ならば3.2.1のはずです。一致させなければビルドが通らないというものではないのですが、一致させることが望ましいです。また、このバージョンではGradleは4.6が推奨されていますので、これを指定してみたらどうでしょうか。


ビルドの経過を表示するBuildビューで、赤!が出ている箇所は存在するでしょうか?(この例はconstraint-layoutをわざと存在しないバージョンにしてみた)

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/12 13:37

    お返事ありがとうございます。

    新規で1個プロジェクトを立ち上げて同じファイルを見て同じにしてみました。
    --------------------------------------------------------
    minSdkVersion 10→minSdkVersion 15
    targetSdkVersion 10→targetSdkVersion 28
    --------------------------------------------------------
    ですが、エラーメッセージは変わらず特に何も変化なしでした。

    その後、Android8.0(Oreo)のインストールをしてみたところ同じく変化なしでした。。

    自分の今の課題は「APIレベルが異なるから現在のレベルから上げる」という認識で合っていますでしょうか?

    キャンセル

  • 2018/12/12 16:16

    調べたことでいろいろといじったりしたので、再度質問を立ち上げて見やすくしました。
    解決した際には前回の質問、今回の質問でベストアンサーにさせていただきます。

    URL:
    https://teratail.com/questions/163573?modal=q-comp

    キャンセル

  • 2018/12/12 17:36

    【解決しました!!】
    URL:
    https://teratail.com/questions/163573?modal=q-comp

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る