質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.10%

imagemagickをバージョン指定でインストールしたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,744

score 30

開発委環境はAWSのcloud9です。

rmagickを使うために、ImageMagickをインストールしたのですが、rmagickが対応できるバージョンと違うバージョンがインストールされてしまいました。

$ convert --version
Version: ImageMagick 6.7.8-9 2016-06-22 Q16 http://www.imagemagick.org


バージョンを確認したところ、6.7.8-9と表示されました。

gemfilesにrmagickを記述して、bundle installコマンドを打つと

current directory: /usr/local/rvm/gems/ruby-2.4.1/gems/rmagick-2.16.0/ext/RMagick
/usr/local/rvm/rubies/ruby-2.4.1/bin/ruby -r ./siteconf20181204-11599-b684j3.rb extconf.rb
checking for gcc... yes
checking for Magick-config... no
checking for pkg-config... yes
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
checking for outdated ImageMagick version (<= 6.4.9)... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/local/rvm/rubies/ruby-2.4.1/bin/$(RUBY_BASE_NAME)

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /usr/local/rvm/gems/ruby-2.4.1/extensions/x86_64-linux/2.4.0/rmagick-2.16.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /usr/local/rvm/gems/ruby-2.4.1/gems/rmagick-2.16.0 for inspection.
Results logged to /usr/local/rvm/gems/ruby-2.4.1/extensions/x86_64-linux/2.4.0/rmagick-2.16.0/gem_make.out

An error occurred while installing rmagick (2.16.0), and Bundler cannot continue.
Make sure that `gem install rmagick -v '2.16.0' --source 'https://rubygems.org/'` succeeds before bundling.


いろいろ検索をかけてみると、恐らくImageMagickのバージョンを指定された6.4.9に変更できればうまくいくらしいです。

ローカルの環境でないためcloud9上でバージョンを指定してインストールするコマンドがわかりません。

回答いただけたら嬉しいです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2018/12/04 13:30

    ImageMagick は、どのようにインストールしたのでしょうか?

    キャンセル

  • taishiaaaaa

    2018/12/04 14:01

    sudo yum install imagemagickというコマンドでインストールしました。

    キャンセル

回答 1

checkベストアンサー

0

rmagick のバージョンなどがわかりませんが...

yum で、バージョンを指定して、インストールする方法は、下記になります。

yum に --showduplicates オプションを渡して下記のように検索

sudo yum search --showduplicates ImageMagick


を実行すると下記のように yum を実行した環境で、インストール可能なすべてのバージョンが表示されるので、

ImageMagick-6.5.4.7-7.el6_5.x86_64 : An X application for displaying and manipulating images
ImageMagick-6.7.2.7-6.el6.i686 : An X application for displaying and manipulating images
ImageMagick-6.7.2.7-6.el6.x86_64 : An X application for displaying and manipulating images

希望するバージョンが見つかったら

sudo yum install ImageMagick-6.5.4.7


のようにバージョン部分も含めて指定すると指定したバージョンがインストールされます。
すでにインストールしてあるバージョンより古い場合は、警告が出ると思うので、インストール済みのものを一度アンインストールしてから実行するのが良いと思います。

ちなみに うちで使っている EC2(not AWS Cloud9)では、6.4.9 は、出てこなかったです...


(別解)

rmagick ですが、github 版なら

動作条件が、

Ruby 2.2.0 or later. 

ImageMagick Version 6.4.9 or later (6.×.x). Version 7 is NOT yet supported; ETA April 2019 ( https://github.com/rmagick/rmagick/pull/299 ). You can get ImageMagick from www.imagemagick.org.

となっていて、ImageMagick 6.4.9 以降の 6.x.x であれば、動くとなっているので、Gemfile に

gem 'rmagick', '2.13.2', :git=>'http://github.com/rmagick/rmagick.git'


と github からインストールするよう指定にしたら、現在の ImageMagick のバージョンのままで rmagick をインストールできたりしないでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/05 03:32

    いま別解を試してみたところ
    Could not find gem 'rmagick (= 2.13.2)' in http://github.com/rmagick/rmagick.git (at master@ff60984).
    The source contains 'rmagick' at: 2.16.0
    というエラー文が表示されました。

    キャンセル

  • 2018/12/05 18:27

    無事インストールできました、回答ありがとうございました。
    感謝感謝です。

    キャンセル

  • 2019/02/21 14:34

    同じ問題でこまっているのですが、どのようにすれば解決できましたか?

    キャンセル

  • 2019/04/10 11:42

    gem install rmagick -v '2.16.0' --source 'https://github.com/rmagick/rmagick.git&#039;
    でいけるようです

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る