質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.32%

yumコマンドで指定されたrpmをインストールしたい

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,155

toroleaman

score 104

インターネットに接続していない、redhat6.5の環境にて、
glibc2.12-1.7
をインストールしようとすると、下記のようにインストールできません。

yum localinstall glibc-2.12-1.7.el6.i686.rpm
Loaded plugins:product-id, subscription-manager
This system is not regisered to Red Hat Subscription Management. You can use subscripton-manager to register.
Setting up Local Package Process
Examining XXXX
glibc-2.12-1.7.el6.i686.rpm: does not update installed packeage.
....
Nothing to do

rpmコマンドで既にインストールされているglibcを確認すると、以下のようになっており、
rpm -qa |grep glibc
glibc-2.12-1.149.el6.i686
インストールしようとしているものよりも古いバージョンのglibcがインストールされているため、
バージョンアップできてもおかしくないと思っています。
rpmコマンドでインストールしようとすると、依存関係や競合関係で、うまくインストールができないので、
yumコマンドでインストールしたいのですが、インターネットに接続できない環境なので、
リポジトリの最新化もできないです。

どなたか、Nothing to doが出力される理由はわかりますでしょうか。
バージョンアップできないのでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+4

インストールしようとしているものよりも古いバージョンのglibcがインストールされているため、
バージョンアップできてもおかしくないと思っています。

すでにインストールされている2.12-1.149は、インストールしようとしている2.12-1.7より新しいように見えるのですが。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/06 08:38

    回答ありがとうございました。
    返信遅くなりました。
    2.12-1.149は、インストールしようとしている2.12-1.7より新しいとは、どういうことでしょう?
    1.149より1.7が大きいので1.7のほうか新しいと思ったのですが。

    キャンセル

  • 2018/12/06 08:48

    バージョン番号はふつうの小数と違って、小数点ごとに区切ってつけていきます。1.7、1.8、1.9の次は1.10です。

    キャンセル

  • 2018/12/06 08:48

    横からですが、

    少数の 1.7 と 1.149 を比較するのではありません。

    バージョン番号は、` . ` で分けて、それぞれを比較します。

    1 と 1 は、同じ
    7 と 149 は、149 が大きい。

    よって、1.149 の方が大きいので新しい。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.32%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る