質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.61%

PCからSVIへ疎通できない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,227

narururu

score 107

 前提・実現したいこと

PC-1/PC-2 と R3で疎通できる状態にしたい。
PC-3/PC-4 と R3で疎通できる状態にしたい。
イメージ説明

 発生している問題・エラーメッセージ

PC-1> ping 172.19.101.254
host (172.19.101.254) not reachable
R3#ping 172.19.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.19.100.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


PC-2,3,4も同様の結果

 試したこと

R1(L2SW)の対象インターフェースにアクセスポートでvlan211を設定。

R1#show run int fa1/1
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/1
 switchport access vlan 211
end

R1#show run int fa1/2
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/2
 switchport access vlan 211
end

R1#show run int fa1/3
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/3
 switchport access vlan 211
end


R3(L3SW)の対象インターフェースにvlan211,222とSVIの設定。

R3#show run int fa1/3
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/3
 switchport access vlan 211
end

R3#show run int fa1/4
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/4
 switchport access vlan 222
end
R3#show run int vlan 211
Building configuration...

Current configuration : 66 bytes
!
interface Vlan211
 ip address 172.19.101.254 255.255.254.0
end

R3#show run int vlan 222
Building configuration...

Current configuration : 64 bytes
!
interface Vlan222
 ip address 172.19.1.254 255.255.254.0
end

 

上記の問題を解決できる方いらっしゃいましたら、アドバイスいただけますと助かります(>_<)
以上、ご確認よろしくお願いいたします。

追記

R3#show ip route
~省略~

     172.19.0.0/23 is subnetted, 2 subnets
C       172.19.0.0 is directly connected, Vlan222
C       172.19.100.0 is directly connected, Vlan211
PC-1> show ip

NAME        : PC-1[1]
IP/MASK     : 172.19.100.1/23
GATEWAY     : 172.19.101.254
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10018
RHOST:PORT  : 127.0.0.1:10019
MTU:        : 1500
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • narururu

    2018/12/02 20:09

    なぜか、直接接続しても、応答ないです(>_<)

    キャンセル

  • troch

    2018/12/02 20:12

    SVIは有効化(no shutdown)していますでしょうか?

    キャンセル

  • narururu

    2018/12/02 20:17

    tkmtmktさん、直接接続の場合ですと、ping応答ありました。

    キャンセル

回答 2

check解決した方法

0

皆様アドバイスありがとうございました。

今回の構成ではGNS3というフリーソフトを使って検証していました。
質問内容であるPCからR3への通信は、おそらくGNS3のバグであると考えられます。
設定変更していないにも関わらず、急に疎通ができるようになったからです。

また、別セグメントへの通信ができなかった原因は、各PCにデフォルトゲートウェイの設定をしていなかったことです。大変失礼いたしました。

以上をもちまして、本件はクローズとさせていただきます。
皆様、本当にありがとうございました!☺

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

(config)# ip routing
(config)# interface Vlan211
(config-if)# no shutdown
(config)# interface Vlan222
(config-if)# no shutdown


でどうでしょうか。
参考リンク

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/02 20:27

    ご回答ありがとうございます。trochさん☺

    ご提示いただいた設定は既に投入済みでございます。
    結果は変わらず、ping応答ありません。

    因みに環境はGNS3というフリーソフトを使ってシミュレーションしております。

    キャンセル

  • 2018/12/02 20:38

    先程、pingしたところ、応答がありました。
    特に何も設定変更していないのでGNS3のバグかなと思います。
    今まで似たようなケースがありましたので、もしかしたら、設定が反映されるまでかなりの時間を要するのかもしれません。

    しかし、ここからまた問題があります。
    PC-1からPC-4に対してpingが届かないのです。
    別セグメントでもR3によってルーティングされる認識なのですが、なぜでしょうか。
    私の認識に間違いがなければ、これもGNS3のバグの可能性があるかもです(>_<)

    キャンセル

  • 2018/12/02 20:47

    別セグメントの通信では各PCにデフォルトゲートウェイの設定をしなければならないことを忘れていました。この件については解決しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る