質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.05%

ruby on rails でgenerate コマンドを実行する際のエラーについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,917

score 23

問題点

ruby on rails の勉強をしているのですが、はじめにhttp://localhost:3000/の実行には成功しました。しかし次のステップのhttp://localhost:3000/users/へのアクセスがうまく行きません

端末上でユーザに関するsampleを自動生成しようとしたのですが実行結果が以下の様になってしまいます

端末

~/rails/sample$ bin/rails generate sample user name:string address:string age:integer
Ignoring bindex-0.5.0 because its extensions are not built. Try: gem pristine bindex --version 0.5.0
Ignoring bootsnap-1.3.2 because its extensions are not built. Try: gem pristine bootsnap --version 1.3.2
Ignoring byebug-10.0.2 because its extensions are not built. Try: gem pristine byebug --version 10.0.2
Ignoring ffi-1.9.25 because its extensions are not built. Try: gem pristine ffi --version 1.9.25
Ignoring msgpack-1.2.4 because its extensions are not built. Try: gem pristine msgpack --version 1.2.4
Ignoring nio4r-2.3.1 because its extensions are not built. Try: gem pristine nio4r --version 2.3.1
Ignoring nokogiri-1.8.5 because its extensions are not built. Try: gem pristine nokogiri --version 1.8.5
Ignoring pg-1.1.3 because its extensions are not built. Try: gem pristine pg --version 1.1.3
Ignoring puma-3.12.0 because its extensions are not built. Try: gem pristine puma --version 3.12.0
Ignoring sqlite3-1.3.13 because its extensions are not built. Try: gem pristine sqlite3 --version 1.3.13
Ignoring websocket-driver-0.7.0 because its extensions are not built. Try: gem pristine websocket-driver --version 0.7.0
Traceback (most recent call last):
22: from /var/lib/gems/2.5.0/gems/spring-2.0.2/bin/spring:49:in <main>'     21: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/client.rb:30:in run'
20: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in call'     19: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/server.rb:9:in call'
18: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'     17: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
16: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/server.rb:9:in <top (required)>'     15: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
14: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'     13: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/commands.rb:4:in <top (required)>'
12: from /var/lib/gems/2.5.0/gems/spring-2.0.2/lib/spring/commands.rb:33:in <module:Spring>'     11: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
10: from /home/yuya/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'      9: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/setup.rb:20:in <top (required)>'
8: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler.rb:107:in setup'      7: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/runtime.rb:20:in setup'
6: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/runtime.rb:108:in block in definition_method'      5: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/definition.rb:226:in requested_specs'
4: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/definition.rb:237:in specs_for'      3: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/definition.rb:170:in specs'
2: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/spec_set.rb:85:in materialize'      1: from /var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/spec_set.rb:85:in map!'
/var/lib/gems/2.5.0/gems/bundler-1.17.1/lib/bundler/spec_set.rb:91:in `block in materialize': Could not find nokogiri-1.8.5 in any of the sources (Bundler::GemNotFound)

どのようにすればエラーが解決されるのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

ほぼ同じエラーログがありました。
https://qiita.com/r_hata/items/74175720f693527b6b86

rbenv exec gem install bundler
rbenv rehash
bundle install

らしいです

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.05%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る