質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.57%

【rails】RMagickのGemfileでのインストールが失敗する

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,137

ayachika

score 36

いつもお世話になります。
現在Webサイトの作成中の初心者です。
今回は画像のリサイズのための前準備でエラーが出てしまったため、質問させてください。

今起こっているエラー

投稿画像のサイズ指定をしたいと思い、インターネット上で調べたところ、RMagickを使って画像のリサイズを行えると書いてありました。Carrierwaveで画像をリサイズするを参考にしました。

しかし、サイトに上記のサイトに記載してあるとおりに単純にbundle installをすると以下のようなエラーが出てしまいました。

①まず、今回画像のリサイズに必要なrmagickをGemfileに記述しインストールする。

#Gemfile
(略)
gem 'carrierwave'
gem 'rmagick' #今回追記
(略)

ターミナルでbundle installを実行。以下のようなエラーが出る。

#ターミナル

An error occurred while
installing rmagick (2.16.0), and
Bundler cannot continue.
Make sure that `gem install rmagick
-v '2.16.0' --source
'https://rubygems.org/'` succeeds
before bundling.

In Gemfile:
  rmagick

試してみたこと

・公式のRubygemのページに行き、最新のバージョンを確認し、記述しなおす

gem 'rmagick', '2.16.0'


と記載してみるも、同様のエラーが出る。

・RMagicをPCにインストールし、そのあとbundle installしてみる。

そこでこちらのサイトを参考にRMagick を Windows にインストールする方法、imagemagickをPCにインストールしました。
こちらからimagemagickをダウンロード

インストールの完了

そのあと、最初と同じようにbundle installをしたのですが、エラー結果は同じものが出てしまいました。

RMagick を Windows にインストールする方法によると、環境変数の設定などが必要と書いてあり、それが今回の場合も必要なのかどうかわかりません。
※ほかにも、単純にGemfileの記述を記載し、rmagickのインストールをしているサイトがいくつかあったため。

現在の環境

AWSのcloud9を使用しています。
rubyのバージョンは 2.4.1p111
railsのバージョンはRails 5.0.7 です。

どなたか、解決策をご助言いただける方がいらっしゃいましたらよろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asm

    2018/12/01 20:59

    環境がよく分かりません。 windowsに入れようとしているのでしょうか?

    キャンセル

  • ayachika

    2018/12/01 21:43

    asm様 コメントありがとうございます。はい、windowsに入れようとしています。そしてコードはcloud9で書いています。

    キャンセル

回答 1

checkベストアンサー

0

試してみました。

https://legacy.imagemagick.org/script/download.php#windowsから
ruby -vの実行結果の末尾が

  • [x64-mingw32]ならば、x64-dll.exe
  • [i386-mingw32]ならば、x86-dll.exe

を選びインストール(Q8とQ16 HDRIの有無は必要に応じて)

インストール時には画像にもあるAdd System PATHDevelopment headersのチェックを忘れずに

コマンドプロンプトを一度閉じてスタートメニューから開き直す
分からなかったらwindowsをログアウト→ログインして開き直す

bundle install

ImageMagickをインストールしたフォルダを開き全てのDLLをrubyインストールフォルダのbin\内にコピー

以上の手順でインストール及びロードを確認しました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/02 09:15

    はい、ありがとうございます。似たような事例がないかもう少し検索してみます!

    キャンセル

  • 2018/12/02 09:20

    sudo apt-get install libmagickwand-dev
    sudo yum install gcc ImageMagick-devel make which

    どっちかだと思いますよ
    Ubuntu系ならapt-get
    Centos/RedHad系ならyum

    キャンセル

  • 2018/12/02 09:51

    ありがとうございます。まだまだ知識が足りておらずすみません。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.57%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る