質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.93%

capybara-webkitがインストールできず、bundleが通らない

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,225

okayamaken

score 8

railsでアプリケーション構築を行っています。
rbenvでgemsetを作成し直したところ、bundleが通らなくなりました。

原因はcapybara-webkitがインストールできないからというところで試行錯誤しているところです。
原因が特定できずおります、どなたかアドバイスいただけますと幸いでございます。

実行環境
・mojaveruby 2.5.3rails 5.1postgres 10.1

bundle install

Fetching capybara-webkit 1.15.1
Installing capybara-webkit 1.15.1 with native extensions
Errno::EACCES: Permission denied @ rb_sysopen - /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1/.gitignore
An error occurred while installing capybara-webkit (1.15.1), and Bundler cannot continue.
Make sure that `gem install capybara-webkit -v '1.15.1' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  capybara-webkit

実行コード
$ sudo gem install capybara-webkit -v '1.15.1' --source 'https://rubygems.org/'

Password:
Building native extensions. This could take a while...
ERROR:  Error installing capybara-webkit:
    ERROR: Failed to build gem native extension.

    current directory: /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1
/Users/user_name/.rbenv/versions/2.5.3/bin/ruby -r ./siteconf20181127-29269-1wqpkb0.rb extconf.rb
Info: creating stash file /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1/.qmake.stash
cd src/ && ( test -e Makefile.webkit_server || /usr/local/opt/qt/bin/qmake -o Makefile.webkit_server /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1/src/webkit_server.pro ) && /Applications/Xcode.app/Contents/Developer/usr/bin/make -f Makefile.webkit_server
Project ERROR: No QtWebKit installation found. QtWebKit is no longer included with Qt 5.6, so you may need to install it separately.
make: *** [sub-src-webkit_server-pro-make_first-ordered] Error 3
Command 'make  --jobs=4' failed

current directory: /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1
make "DESTDIR=" clean
cd src/ && ( test -e Makefile.webkit_server || /usr/local/opt/qt/bin/qmake -o Makefile.webkit_server /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1/src/webkit_server.pro ) && /Applications/Xcode.app/Contents/Developer/usr/bin/make -f Makefile.webkit_server clean
Project ERROR: No QtWebKit installation found. QtWebKit is no longer included with Qt 5.6, so you may need to install it separately.
make: *** [sub-src-webkit_server-pro-clean-ordered] Error 3

current directory: /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1
make "DESTDIR="
cd src/ && ( test -e Makefile.webkit_server || /usr/local/opt/qt/bin/qmake -o Makefile.webkit_server /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1/src/webkit_server.pro ) && /Applications/Xcode.app/Contents/Developer/usr/bin/make -f Makefile.webkit_server
Project ERROR: No QtWebKit installation found. QtWebKit is no longer included with Qt 5.6, so you may need to install it separately.
make: *** [sub-src-webkit_server-pro-make_first-ordered] Error 3

make failed, exit code 2

Gem files will remain installed in /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/gems/capybara-webkit-1.15.1 for inspection.
Results logged to /Users/user_name/.rbenv/versions/2.5.3/gemsets/gem-name/extensions/x86_64-darwin-18/2.5.0-static/capybara-webkit-1.15.1/gem_make.out

### 追記

$ brew extract --help
Look through repository history to find the most recent version of formula and
create a copy in tap/Formula/formula@version.rb. If the tap is not
installed yet, attempt to install/clone the tap before continuing.

        --version                    Extract the provided version of formula
                                     instead of the most recent.
    -f, --force                      Override warnings and enable potentially
                                     unsafe operations.
    -d, --debug                      Display any debugging information.
    -h, --help                       Show this message.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • matsuand

    2018/11/28 18:27

    エラーに "QtWebKit is no longer included with Qt 5.6" と示されていますから、これに応じて対処するのではないでしょうか?

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る