質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

phpMyAdmin

phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。

解決済

Cent OS7 にphpMyAdminがインストールできない。

ayaseaya
ayaseaya

総合スコア0

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

phpMyAdmin

phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。

2回答

0評価

2クリップ

3085閲覧

投稿2018/11/25 10:05

編集2022/01/12 10:58

いつもありがとうございます。
タイトルの通り、さくらVPSのCent OS7にphpMyAdminがインストール出来なくて困っています。

エラー内容としては、

error

Error: Package: php-tcpdf-dejavu-sans-fonts-6.2.26-1.el7.noarch (epel) Requires: dejavu-sans-fonts Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1()(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libexslt.so.0()(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1(LIBXML2_1.0.11)(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1(LIBXML2_1.0.13)(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1(LIBXML2_1.0.18)(64bit) Error: Package: php-gd-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libXpm.so.4()(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1(LIBXML2_1.0.22)(64bit) Error: Package: php-xml-7.2.12-1.el7.remi.x86_64 (remi-php72) Requires: libxslt.so.1(LIBXML2_1.0.24)(64bit) Error: Package: gd-last-2.2.5-5.el7.remi.x86_64 (remi-safe) Requires: libwebp.so.4()(64bit) Error: Package: gd-last-2.2.5-5.el7.remi.x86_64 (remi-safe) Requires: libXpm.so.4()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

上記のようなものが出ます。

https://teratail.com/questions/57138
https://goo.gl/ka23w3
過去の質問を参考に色々と試しましたが解決しません。
どなたか知恵を貸していただけませんでしょうか。

PHPは、PHP 7.2.12です。

yum --enablerepo=remi,remi-php72 install phpMyAdmin

で試しております。

宜しくお願いします。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

CHERRY
CHERRY

2018/11/26 01:36

このエラーの前には、どのようなメッセージが出ていますか?
ayaseaya
ayaseaya

2018/11/26 03:50

ありがとうございます。追記させていただきました。宜しくお願いします。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

phpMyAdmin

phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。