質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

bundle install で依存関係のエラーが発生する

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,173

shino-shino

score 12

以下のようなGemfileの設定で bundle install をするとエラーが出ました。
これを解決する方法を教えてください。
gem 'activesupport-json_encoder' を追加してからエラーを吐くようになったのですが、'activesupport-json_encoder'はどうしても必要です。

このようなgemの依存関係を解決するにはどうしたら良いのでしょうか。

Gemfile の設定

source 'https://rubygems.org'

ruby '2.4.1'

git_source(:github) do |repo_name|
  repo_name = "#{repo_name}/#{repo_name}" unless repo_name.include?("/")
  "https://github.com/#{repo_name}.git"
end

gem 'activerecord-import'
gem 'annotate'
gem 'awesome_print'
gem 'aws-sdk'
gem 'bootstrap-sass'
gem 'bower-rails'
gem 'browser'
gem 'carrierwave'
gem 'coffee-rails', '~> 4.2'
gem 'compass-rails'
gem 'devise'
gem 'devise-i18n'
gem 'devise_invitable'
gem 'dotenv-rails'
gem 'draper'
gem 'enum_help'
gem 'fog'
gem 'font-awesome-rails'
gem 'haml-rails'
gem 'jbuilder', '~> 2.5'
gem 'jquery-rails'
gem 'js_cookie_rails'
gem 'kaminari'
gem 'mysql2', '>= 0.3.18', '< 0.5'
gem 'puma', '~> 3.7'
gem 'rails', '~> 5.1.1'
gem 'rails-i18n'
gem 'rails_12factor'
gem 'ransack'
gem 'rmagick'
gem 'sass-rails', '~> 5.0'
gem 'simple_form'
gem 'toastr-rails'
gem 'turbolinks', '~> 5'
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
gem 'uglifier', '>= 1.3.0'
gem "gon"
gem 'aws-sdk-rails'
gem 'fluent-plugin-forest'
gem 'wkhtmltopdf-binary'
gem 'wicked_pdf'
gem 'unf'
gem 'barby'
gem 'rqrcode'
gem 'pusher'
gem 'line-bot-api'
gem 'jwt'
gem 'chunky_png'
gem 'activesupport-json_encoder'

group :development, :test do
  gem 'bullet'
  gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
  gem 'capybara', '~> 2.13'
  gem 'erb2haml'
  gem 'factory_girl_rails'
  gem 'faker'
  gem 'selenium-webdriver'
  gem 'rails-erd'
  gem 'rspec-rails'
  gem 'capistrano'
  gem 'capistrano-bundler'
  gem 'capistrano-rails'
  gem 'capistrano-rbenv'
end

group :development do
  gem 'better_errors'
  gem 'binding_of_caller'
  gem 'listen', '>= 3.0.5', '< 3.2'
  gem 'spring'
  gem 'spring-watcher-listen', '~> 2.0.0'
  gem 'web-console', '>= 3.3.0'
end

group :production, :staging do
    gem 'unicorn'
    gem 'dotenv-rails'
    gem 'dalli'
    gem 'dalli-elasticache'
end

発生したエラー

Bundler could not find compatible versions for gem "actionmailer":
  In Gemfile:
    devise_invitable was resolved to 1.7.5, which depends on
      actionmailer (>= 4.1.0)

    rails (~> 5.1.1) was resolved to 5.1.2.rc1, which depends on
      actionmailer (= 5.1.2.rc1)

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    draper was resolved to 3.0.1, which depends on
      actionpack (~> 5.0)

    haml-rails was resolved to 1.0.0, which depends on
      actionpack (>= 4.0.1)

    rails (~> 5.1.1) was resolved to 5.1.2.rc1, which depends on
      actionpack (= 5.1.2.rc1)

    rspec-rails was resolved to 3.8.1, which depends on
      actionpack (>= 3.0)

    simple_form was resolved to 4.0.1, which depends on
      actionpack (>= 5.0)

Bundler could not find compatible versions for gem "activerecord":
  In Gemfile:
    activerecord-import was resolved to 0.27.0, which depends on
      activerecord (>= 3.2)

    annotate was resolved to 2.7.4, which depends on
      activerecord (>= 3.2, < 6.0)

    rails (~> 5.1.1) was resolved to 5.1.2.rc1, which depends on
      activerecord (= 5.1.2.rc1)

    ransack was resolved to 2.1.0, which depends on
      activerecord (>= 5.0)

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    activesupport-json_encoder was resolved to 1.1.0, which depends on
      activesupport (>= 4.1.0, < 5.0)

    carrierwave was resolved to 1.2.3, which depends on
      activesupport (>= 4.0.0)

    draper was resolved to 3.0.1, which depends on
      activesupport (~> 5.0)

    haml-rails was resolved to 1.0.0, which depends on
      activesupport (>= 4.0.1)

    jbuilder (~> 2.5) was resolved to 2.6.2, which depends on
      activesupport (>= 3.0.0, < 5.1)

    kaminari was resolved to 1.1.1, which depends on
      activesupport (>= 4.1.0)

    rails (~> 5.1.1) was resolved to 5.1.2.rc1, which depends on
      activesupport (= 5.1.2.rc1)

    rails-erd was resolved to 1.5.2, which depends on
      activesupport (>= 3.2)

    ransack was resolved to 2.1.0, which depends on
      activesupport (>= 5.0)

    rspec-rails was resolved to 3.8.1, which depends on
      activesupport (>= 3.0)

    spring was resolved to 2.0.2, which depends on
      activesupport (>= 4.2)

Bundler could not find compatible versions for gem "rails":
  In Gemfile:
    rails (~> 5.1.1)

    rspec-rails was resolved to 2.2.0, which depends on
      rails (~> 3.0.0)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Rails 5系列に対応する気がまったくなさそうなので
自分でforkして対応、という事ができないのであれば諦めるしかありません。

Rails 5ではActiveModel::Serializers::JSONを用いる事になります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる