質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.64%

rubyのエンコードのエラーでしょうか?

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,097
退会済みユーザー

退会済みユーザー

はじめまして。

環境
mac os10.10
ruby 2.0.0
git 2.3.2
sourcetree 2.0.5.2

git-export-toolsでの差分抽出時、

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/shellwords.rb:135:in gsub!': invalid byte sequence in US-ASCII (ArgumentError)
from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/shellwords.rb:135:inshellescape'
from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/shellwords.rb:201:in shell escape'
from /Users/g10615/Documents/git/git-export-diff.rb:134:in'
from /Users/***/Documents/git/git-export-diff.rb:134:in'
上記のエラーが返ってきますがrubyのエンコードのエラーでしょうか?
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • pi-chan

    2015/09/08 22:51

    SourceTree のカスタムアクションには、具体的にどのように設定してありますか??
    自分の環境にも同じバージョンをインストールして試しましたが、問題なく使えています。

    キャンセル

  • HSG

    2015/09/09 15:27

    ありがとうございます。
    shellwords.rbの先頭にエンコード指定のソース記述で解決いたしました。
    以前、ruby1.8を使用しておりその時は不具合が無かったんですが、OSのバージョンアップに伴いruby2.0へ変更するとエラーが発生しました。
    rubyのエンコードの扱いが何か変更されたのでしょうか。

    キャンセル

回答 1

0

ちょっと調べてみた結果になってしまいますが(この後にさらに詳しい方がご回答なさることを願います)。
結論としては、「rubyの動作環境」「お使いの環境」「入力されるファイル」など、これに関わる内の何かがUS-ASCIIで、何かがUS-ASCII以外である、ということによるエラーだと思います。

エラー文中、 invalid byte sequence in US-ASCII ということは、「US-ASCIIとしては不正なバイトの並びが検出された」ということです。なのでrubyの動作環境がUS-ASCIIかな、と思います。
この invalid byte sequence in のエラーは「文字列のマッチング」などで出るようです*1。エラー文にも、最初の文(エラーを出した一番深い場所)が shellwords.rb:135:in gsub とあり、やはり比較でエラーが出ていると思います。
エラー文の一番最後(エラーを出した一番浅い場所)が git-export-diff.rb:134:in となっているので、おそらく "git-export-diff.rb" 134行 shellescape がレシーバとした output suffix の、いずれか(もしくは両方)の文字コードがUS-ASCIIでない他の何かなのだと考えられます。
"git-export-diff.rb" 91行で output = File.join(options[:output], dir) としています。ファイル名を扱っているのだと思うので、ここで「rubyの動作文字コード」と「お使いの環境(か入力ファイル)の文字コード」が違ってしまったものと思います。

*1: Rubyのエンコーディング - @tmtms のメモ
長くなり(確証もなく)申し訳ありません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/22 10:31

    >hogashiさん
    rbも読み解いてくださりありがとうございます。
    回答内容を読み勉強させていただきました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる