質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

geruby2.5のはずなのにrails newしたらruby2.3となる

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 537

DrqYuto

score 154

イメージ説明
環境はrumix2で2.3
cmdではruby2.5です。
イメージ説明
前にうまくいかなかったので同じアプリ名で上書きしました。

gem install railsしたらエラー?が出ました。
イメージ説明

ridikでエラー?が出ましたが問題ないでしょうか?
イメージ説明

ridik後にgem install railsしたらサーバが起動しなくなりました。 
イメージ説明

gemfileを2.5.3に変えてもうまく起動しません。
イメージ説明

sqliteインストールできてないということでしょうか?
イメージ説明

sqliteでエラーが出ました。
イメージ説明

こうですか?
イメージ説明

platformでエラー出ました。
イメージ説明

やっとrails sできました。有難う御座います。ですが,2.3のまんまです…
イメージ説明

なぜか2.3が出ました。
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

gem install railsをした時のruby.exeの位置をrailsコマンドは記憶しますので
新しい環境を作成する度にgem install railsをする必要があります。


Windows初期インストール状態からRailsを起動するまでやってみたので作業録です。

  1. RubyInstaller2のrubyinstaller-devkit-2.5.3-1-x86.exeをダウンロードしインストール
  2. コマンドプロンプトを開く
  3. ridk exec pacman -S mingw-w64-i686-sqlite3
  4. gem install sqlite3 --platform=ruby
  5. gem install rails
  6. rails new アプリ名
  7. gem uninstall sqlite3でx86_mingw32をアンインストール
  8. cd アプリ名
  9. rails sしブラウザでlocalhost:3000にアクセスし確認

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/10 21:51

    できませんでした。linuxでやってみます。

    キャンセル

  • 2018/11/10 22:02

    すいません、よく見たら32bit版ですか
    ridk exec pacman -S mingw-w64-i686-sqlite3
    でしたね

    キャンセル

  • 2018/11/11 16:13

    そうです.32でした。rails sできましたが、ruby2.3のようです…

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる