質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

PHP5.3.28から5.3.3への変更につきまして

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 886

chakuo_3810

score 11

PHPのバージョン変更についての質問です。

当方PHPに関して全くの初心者なのですが、故ありまして商用レンタルサーバーの基盤システムバージョンアップに伴う、ネットショップ用PHPプログラムの変更点を調べなければならなくなりました。

PHPプログラムは現在ver.5.3.28で動いておりまして、基盤システムバージョンアップ後はver.5.3.3に変更になります。
(脆弱性対応のため、安全性の高いバージョンに変更するという事だと思います。)
なので、プログラムも現在5.3.28で動いているのですが、5.3.3対応に変更しなくてはならないようです。
ショップオーナーは5.6.×等へのアップグレードは、時間も無いため今回のバージョンアップでは考えていないという事なので、他のバージョンにする事はできません。

基盤システムバージョンアップは今年9月以降順次という事なのでおそらくあまり時間が無く、ネットの情報もできるだけ調べてはいるのですが、なにぶん初心者なのでこれかなと思う情報に行き当たらず途方にくれております…。
どなたかPHPプログラムの変更点等できれば分かり易く解説してあるサイト等ご存知でしたらお教え頂けないでしょうか。
よろしくお願い致します。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

PHP5.3.28からPHP5.3.3にダウングレードするんですか?
それとも、PHP5.3.28→PHP5.6.3とかなのでしょうか???
アップグレードなら対象のバージョンを記載して下さい。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/04 22:22

    色々と教えて頂き感謝致します。
    開発元は全く違う会社なので、
    (そちらでは開発者は既に在籍しておらず、他にPHPが扱える者もいないのか、出来ないと言われたそうです…)
    開発環境はこれから構築するような状況です…。大変参考になります。ありがとうございます。

    キャンセル

  • 2015/09/05 02:36

    私も、CakePHP1系統、2系統どちらでも開発しているので何か困ったら助言程度ですが出来るかと思います。
    サーバに関しても多少知識はありますので^^;
    気軽に声かけて下さ〜い。

    キャンセル

  • 2015/09/05 08:00

    おはようございます。ご回答感謝致します!大変心強いです<(_ _)>。
    開発環境をできるだけ早く整えて動作確認等がんばってみたいと思います。
    解らない事がでましたらまたご助言頂けると本当に助かります。
    よろしくお願い致します。ありがとうございます!

    キャンセル

0

脆弱性が多数発見されているサポート終了したバージョンは使わない方が良いと思うのですが。。。
https://bugs.php.net/search.php?cmd=display&order_by=php_version&direction=ASC&limit=30&status=Open&begin=1290
これ5.3.3以降に発生した5.3系の脆弱性のなかで、beforeと書かれている場合はすべて該当しちゃいます。

こういう取り組みもされているので、さらされないようお気を付け下さい。
http://www.ipa.go.jp/about/press/20150903.html

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/04 22:34 編集

    ご回答ありがとうございます。
    脆弱性の問題につきましては十分承知してはいるのですが、今回時間が殆ど無いと思われる事、またショップオーナーの意向で、上位バージョンに移行する考えはあるが取り急ぎ現状のプログラムがサーバーの基盤システムバージョンアップ後でも動くようにして欲しいという事で、ご質問させて頂きました。なにぶん初心者で申し訳ありません。ご忠告本当にありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る