質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.36%

  • Python 3.x

    8408questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Raspberry Pi

    978questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • dlib

    18questions

    dlibは、機械学習のC++の画像処理ライブラリの一つ。性能の高い顔の器官検出が簡単にでき、Pythonバインドもあります。オープンソースで無料で使用でき、機械学習以外の様々な機能も搭載されています。

dlibの顔認証エラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 218

rionvel

score 3

https://www.pyimagesearch.com/2017/04/24/eye-blink-detection-opencv-python-dlib/

まばたきを検出するプログラムを動かしてみようとしたところ、dlibのところでエラーが出ました。

$ python detect_blinks_np.py --shape-predictor shape_predictor_68_face_landmarks.dat


上記のコマンドで以下のエラーが発生しました。

ape_predictor_68_face_landmarks.dat
[INFO] loading facial landmark predictor...
Traceback (most recent call last):
  File "detect_blinks_np.py", line 53, in <module>
    detector = dlib.get_frontal_face_detector()
AttributeError: module 'dlib' has no attribute 'get_frontal_face_detector'

ソースコードの該当箇所

print("[INFO] loading facial landmark predictor...")
detector = dlib.get_frontal_face_detector()
predictor = dlib.shape_predictor(args[> "shape_predictor"])

python3.6.5
raspberry pi3 modelB
rasbian stretch
dlib 19.16
opencv 3.1.0

import dlibはエラーなくできます。インストールはpip install dlibでしています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • can110

    2018/11/06 18:19

    追記ありがとうございます。可能性のひとつとして回答をしました。

    キャンセル

  • rionvel

    2018/11/06 18:38

    ありがとうございます。

    キャンセル

  • can110

    2018/11/06 18:43

    あれ?回答ボタン押し忘れてました。失礼しました。

    キャンセル

回答 1

checkベストアンサー

0

pip install dlibを実行されたということですのでpython2.7環境にインストールされていると思います。
pyhont3.x環境で使うためにはpip3 install dlibする必要があると思います。
virtualenv利用しているのであれば、その仮想環境にdlibインストールする必要があります。

具体的な手順についてはInstall dlib (the easy, complete guide)Installing dlib on Raspberry Pi/Raspbianが参考になるかと思います。この手順でもvirtualenvを利用しています。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/07 14:45

    pip3 install dlib実行結果
    Command
    "/home/pi/.virtualenvs/cv-python3/bin/python
    -u
    -c
    "import setuptools,
    tokenize;
    __file__='/tmp/pip-install-w4ykbv4l/dlib/setup.py';
    f=getattr(tokenize, 'open', open)(__file__);
    code=f.read().replace('\r\n', '\n');
    f.close();
    exec(compile(code, __file__, 'exec'))"
    install
    --record /tmp/pip-record-weba6njw/install-record.txt
    --single-version-externally-managed
    --compile --install-headers
    /home/pi/.virtualenvs/cv-python3/include/site/python3.6/dlib"
    failed with error code 1 in
    /tmp/pip-install-w4ykbv4l/dlib/

    提案どおりpip3で行うと上記のエラーでinstallできていないようです。

    キャンセル

  • 2018/11/07 15:00

    あ、ちょっと嘘書いてました。virtualenv利用しているのであればpip install ~でよいです。ただしその前にライブラリのインストールは必要です。
    参考URLを回答に追記します。

    キャンセル

  • 2018/11/07 15:28

    pip install dlib実行結果
    Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
    Requirement already satisfied: dlib in /usr/local/lib/python3.5/dist-packages (19.16.0)
    URLとても参考になります。ありがとうございます。

    そこで新たな問題が発生してしまったのですが、使用しているのはpython3.6であるのにpython3.5のやつがインストールされてしまっているようです。なにかアドバイス等あればお願いします。

    キャンセル

  • 2018/11/07 15:32

    ご自身で作成された(はずの)3.6の仮想環境に切り替えたうえでpipインストールされたでしょうか?
    すみません、当方再現環境ないのでこれ以上はお役に立てません。。

    キャンセル

  • 2018/11/07 15:34

    アドバイスありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Python 3.x

    8408questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Raspberry Pi

    978questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • dlib

    18questions

    dlibは、機械学習のC++の画像処理ライブラリの一つ。性能の高い顔の器官検出が簡単にでき、Pythonバインドもあります。オープンソースで無料で使用でき、機械学習以外の様々な機能も搭載されています。