質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby

    9437questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8859questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    3182questions

  • Bootstrap

    1298questions

    BootstrapはウェブサイトデザインやUIのWebアプリケーションを素早く 作成する可能なCSSフレームワークです。 Twitter風のデザインを作成することができます。

【Rails5】bootstrap4の導入エラー

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,203

ningen

score 22

rails5 ruby2.5.1

困っていること

gem 'bootstrap', '~> 4.1.3'をインストールしたらRuntimeErrorが表示されます。
イメージ説明

現状

これまではbootstrap-sassを使用してきましたが、Bootstrap4を導入したいと思っています。

Gemfile

gem 'bootstrap-sass'
gem 'bootstrap', '~> 4.1.3'

bundle install後にrailsサーバーに繋げたらwaringがでてきたのでこの2つは一緒にいてはダメなのかなと思い

gem 'bootstrap-sass' ←削除
gem 'bootstrap', '~> 4.1.3'


一先ずwarningは消えましたがRuntimeErrorが出てる状態です。

試してみたこと

GitHubの内容に従ってファイルの中身を修正していきました。
1
app/assets/stylesheets/application.scss

*= require font-awesome
 *= require_tree .
 *= require_self
 *= require 'css/lightbox'
 */

// Custom bootstrap variables must be set or imported *before* bootstrap.
 @import "bootstrap";


2 拡張子をcssからscssへ

$ mv app/assets/stylesheets/application.css app/assets/stylesheets/application.scss



javascripts/application.js 

//
//= require rails-ujs
//= require jquery3
//= require popper
//= require bootstrap
//= require activestorage
//= require turbolinks
//= require_tree .
//= require js/lightbox
//= require bootstrap-sprockets
//= require data-confirm-modal


4
現在のGemfile

gem 'activeadmin'
gem 'bootsnap', '>= 1.1.0', require: false
gem 'bootstrap-will_paginate'
gem 'cancancan'
gem 'carrierwave'
gem 'coffee-rails', '~> 4.2'
gem 'devise'
gem 'execjs'
gem 'jbuilder', '~> 2.5'
gem 'jquery-rails'
gem 'kaminari'
gem 'less-rails', git: 'https://github.com/MustafaZain/less-rails'
gem 'paperclip'
gem 'puma', '~> 3.11'
gem 'rails', '~> 5.2.1'
gem 'rails_admin'
gem 'ransack'
gem 'sass-rails', '~> 5.0.6'
gem 'sprockets', '3.7.2'
gem 'therubyracer'
gem 'turbolinks', '~> 5'
gem 'twitter-bootstrap-rails'
gem 'uglifier', '>= 1.3.0'
gem 'will_paginate'
gem 'annotate'
gem 'data-confirm-modal'
gem "font-awesome-rails"
gem 'bootstrap', '~> 4.1.3'

まとめ

RuntimeErrorについて調べてみましたが、?っと言う感じになりました。
こちらにもやさしく導入方法が書いてありましたが同じことをしているのにエラーがでてしまいます。

質問投稿後に気が付いたこと

ExecJS::RubyRacerRuntime is not supported. Please replace therubyracer with mini_racer in your Gemfile or use Node.js as ExecJS runtime.

とは、therubyracerをmini_racerに置き換えるないとNode.jsで依存性がない。
と言うことだと考えています。

けれど、
therubyracerをmini_racerに置き換える方法がわかりません。
調べてみましたが…
参考サイト

Gemfile修正

-gem 'therubyracer'
+gem 'mini_racer', '~> 0.2.4'


bundle install で以下のエラーがでました。
イメージ説明
イメージ説明
![イメージ説明]

赤文字

An error occurred while installing mini_racer (0.2.4), and Bundler cannot continue.
Make sure that `gem install mini_racer -v '0.2.4' --source 'https://rubygems.org/'` succeeds before bundling.

mini_racerに従ってインストールしてもエラーが出ます。

Gemfile.lock

     -therubyracer (0.12.3)
     +mini_racer (0.2.4)
       libv8 (~> 3.16.14.15)
      ref


を変更してみましたがエラーがうまくいきません。

libv8のバージョンをあげてみました。

イメージ説明
イメージ説明

それでもやっぱりだめみたいですね。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

therubyracerをmini_racerに置き換える方法がわかりません。

Gemfileにある、gem 'therubyracer'という行をgem 'mini_racer'と書き換えて、bundle installしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/06 21:04

    回答ありがとうございます!
    試したところエラーがでてうまくインストールされませんでした。
    エラー内容や、それから試してみたことを質問内容にまとめてみましたので、
    もしよければ教えていただきたいです。

    キャンセル

  • 2018/11/06 21:12

    libv8のバージョンが低かったです。一度バージョンアップしてもう一度試してみます。

    キャンセル

  • 2018/11/06 21:24

    バージョンをあげてもエラーがでました…

    キャンセル

+1

原因かどうかはわかりませんが
selfとtreeの順番が逆になっているのは意図的ですかね...
あとうろ覚えなんですが、importが必要ではなかったですか?

* application.scss

*= require_self
*= require font-awesome
*= require 'css/lightbox'
*= require_tree .
*/

@import "bootstrap";

エラーとは関係ないと思いますが、

// application.js

//= require bootstrap
//= require bootstrap-sprockets


は片方だけでいいのでは?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/06 21:05

    回答ありがとうございます!
    そうなんですね!ちょっと試してみたいと思います。

    キャンセル

同じタグがついた質問を見る

  • Ruby

    9437questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8859questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    3182questions

  • Bootstrap

    1298questions

    BootstrapはウェブサイトデザインやUIのWebアプリケーションを素早く 作成する可能なCSSフレームワークです。 Twitter風のデザインを作成することができます。