質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.64%

rails開発環境エラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 747

meidochan

score 15

rubyの勉強が一通り終わったので、さて次はrails tutorialの勉強をしようと思い、仮想環境を構築しようとしたところで壁にぶつかりました。

現在の状況としましては、https://github.com/yasslab/railstutorial.jp_starter_kit のページに従ってvagrantのboxをダウンロードし、vagrant upしてsshログインするところまでは無事終わっているのですが、railsのversionを指定しようと

$ rbenv install 2.3.0


上記コマンドを打ったところ下記エラーが出てしまいました。

BUILD FAILED (Ubuntu 17.10 using ruby-build 20181019-4-g1d9b812)

Inspect or clean up the working tree at /tmp/ruby-build.20181105034353.3605
Results logged to /tmp/ruby-build.20181105034353.3605.log

Last 10 log lines:

verconf.h updated
compiling loadpath.c
linking static-library libruby-static.a
ar: `u' modifier ignored since `D' is the default (see `U')
Aborted (core dumped)
uncommon.mk:654: recipe for target 'enc.mk' failed
make: *** [enc.mk] Error 134
make: *** Waiting for unfinished jobs....
verifying static-library libruby-static.a

ダウンロードが失敗しているようなのですが、ググっても原因がわかりませんでした。

解決方法を知りたいです。よろしくお願いします。

又、linuxの知識がなさ過ぎて、エラー文を見ても何が問題なのか推測することもできませんでしたので勉強しようと思います。
皆様がどのようにlinuxを勉強しているのか、おすすめの本などありましたら教えていただけると幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

質問拝見させていただきました。
おそらくGCCのバージョンがあっておらず、ビルドに失敗しているようです。

vagrantイメージがubuntu 17.10を使用しているため、デフォルトでGCC7系を使用するようになっています。

Ruby2.4以前のバージョンはGCC7系でのコンパイルはできないため、下記の通りGCCのバージョンを下げてコンパイルを実行してください。

  • gcc6系のインストール
$ sudo apt-get install gcc-6
  • バージョンを指定してrubyのインストール
$ CC=/usr/bin/gcc-6 rbenv install 2.3.0

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/06 20:44

    回答ありがとうございます、無事できました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る