質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.95%

rbenvでruby2.6.0-devをインストールできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,214
退会済みユーザー

退会済みユーザー

Ubuntu 18.10 Mateにrbenvでruby2.6.0-devをインストールしようとしたら、
下記のようなメッセージが出ました。

$ rbenv install 2.6.0-dev
Cloning https://github.com/ruby/ruby.git...
Installing ruby-trunk...

BUILD FAILED (Ubuntu 18.10 using ruby-build 20181019-2-gd49b8a1)

Inspect or clean up the working tree at /tmp/ruby-build.20181025134329.31858
Results logged to /tmp/ruby-build.20181025134329.31858.log

Last 10 log lines:
/tmp/ruby-build.20181025134329.31858 ~
Cloning into 'ruby-trunk'...
/tmp/ruby-build.20181025134329.31858/ruby-trunk /tmp/ruby-build.20181025134329.31858 ~
checking for ruby... false
configure: error: cannot run /bin/bash tool/config.sub

/bin/bashの存在は確認できたのですが、tool/config.subの存在は確認できませんでした。

どうすればruby2.6.0-devをインストールできるのかご教授願います。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

checking for ruby... falseと出ていますが、最新版のRubyをビルドするには、Rubyが必要です(最新版でない場合は、事前にRuby処理を済ませたものをパッケージ化してあるので、いきなり入れても問題ありません)。

システムワイド、あるいはrbenvで、事前に安定版のRubyを入れてみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/25 16:39

    安定版であるruby2.5.3を入れました。その後、ruby2.6.0-devをインストールすると、下記のメッセージが出ました!

    ```
    $ rbenv install 2.6.0-dev
    Cloning https://github.com/ruby/ruby.git...
    Installing ruby-trunk...

    BUILD FAILED (Ubuntu 18.10 using ruby-build 20181019-2-gd49b8a1)

    Inspect or clean up the working tree at /tmp/ruby-build.20181025163451.17912
    Results logged to /tmp/ruby-build.20181025163451.17912.log

    Last 10 log lines:
    /tmp/ruby-build.20181025163451.17912 ~
    Cloning into 'ruby-trunk'...
    /tmp/ruby-build.20181025163451.17912/ruby-trunk /tmp/ruby-build.20181025163451.17912 ~
    checking for ruby... false
    configure: error: cannot run /bin/bash tool/config.sub

    ```
    これってどうやったらインストールできますかね?

    キャンセル

  • 2018/10/25 16:41

    うーん、最新版はインストール自体、技量が必要そうですよね……

    キャンセル

  • 2018/10/25 16:44

    そうでしたか、今回は安定版を使います。ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.95%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る