質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

PHP5.6でOracle PDOを使用する方法について

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 4,535

MAD_Engineer

score 26

お世話になります。PHPにオラクルのPDOをインストールしようとしているのですが、うまくいかず、困っています。ご存知の方がおられましたらご教授のほどよろしくお願いします。なおOSはCentOS6.7です。

<現在までに行ったこと> 

① オラクル12.1のクライアントをユニバーサルインストーラーでインストール。特に複雑な指定は行わず、言語で日本語を追加した程度です。

② PHP5.6をremiリポジトリを指定してyumでインストール。

③ /etc/sysconfig/httpdに環境変数(ORACLE_BASE、ORACLE_HOME、NLS_LANG、LD_LIBRARY_PATH)追加
 ORA_BASE=/opt/app/oracle
 ORACLE_HOME=${ORA_BASE}/product/12.1.0/client_1
 NLS_LANG=Japanese_Japan.UTF8
 LD_LIBRARY_PATH=${ORACLE_HOME}/lib

④ apache再起動

⑤ PHP関数のphpinfo()による確認
 ・PDOの表
 PDOの表は、「PDO support」列の「PDO drivers」の行の「enabled」列に「oci」が表示されています。
 ・PDO_OCIの表
 PDO_OCIの表は、タイトル行のみ(「PDO Driver for OCI 8 and later」「enabled」)が表示されている状態です。
 ・Environmentの表
 上記③で設定した環境変数が正しく表示されています。
 ・その他
 OCI/PDO関連の拡張は/etc/php.d配下の「/etc/php.d/20-pdo.ini」「/etc/php.d/20-oci8.ini」「/etc/php.d/30-pdo_oci.ini」で行っており「Additional .ini files parsed」としても表示されています。
 /etc/php.d/20-pdo.ini の内容
 extension=pdo.so
 /etc/php.d/20-oci8.ini の内容
 extension=oci8.so
 /etc/php.d/30-pdo_oci.ini の内容
 extension=pdo_oci.so
 上記DLLは、extension_dir で指定した箇所に存在しています。

⑥ PHP関数のvar_dump(get_defined_functions())による確認
oci_connect等が表示されることから、OCIは正しくインストールされています。(簡単なプログラムでオラクルからのテーブル取得に成功しました。)
 
以上よろしくお願いします。 
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

どううまくいかないのかを詳しく記載してみてください。
たとえば「ApacheのログにXXXXというエラーメッセージが表示される」など。
また、エラーを出している部分のPHPのソースもあるとよいかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/08/31 22:28

    お世話になります。ご回答ありがとうございます。
    この件、どうやらPDO自体はおそらく使えるだろうということが判明しました。
    ご回答を頂くまでは、phpinfoのPDO_OCIが正しく表示されていなかったので
    PDOそのものを試すことはしていませんでした。

    ご回答を頂いて念のためPDOでオラクルに接続して簡単なSELECT文を発行するプログラムを作成したところ、問題なく処理できていることが判明しました。

    ただ、phpinfoのPDO_OCIが正しく表示されないのは、PDO関連の設定に何らかの不備があるのではと懸念している次第です。

    解決とは言い難いですが、PDOがおそらく使えるだろうと判明したことは大きな進捗でした。

    ありがとうございました。

    キャンセル

  • 2015/08/31 22:43

    手元の(pdo_ociを使っている)環境で確認してみましたが、
    php_oci.so としては表示されないみたいですね。
    こんなものなのかもしれません?
    $ php -i (抜粋)
    PDO support => enabled
    PDO drivers => mysql, oci, pgsql, sqlite

    PDO_OCI
    PDO Driver for OCI 8 and later => enabled

    キャンセル

0

お世話になります。回答が遅れて申し訳ありません。
当方の環境でも同様のことが確認できました。ありがとうございます。
(コマンドラインのphpに-iというオプションがあることを初めて知りました。ありがとうございます。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる