質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.59%

急にrailsコマンドが使えなくなった

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 574

Piesuke

score 15

急にrailsコマンドが使えなくなりました

rails -vとrails newだけはできるのですが、既存のファイルは

Usage:
  rails new APP_PATH [options]

以下省略

と出て、rails newで新しく作ったファイルは、

/Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-3.0.5/lib/active_support/values/time_zone.rb:272: warning: circular argument reference - now
/Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-3.0.5/lib/active_support/core_ext/string/output_safety.rb:68: warning: constant ::Fixnum is deprecated
/Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:116:in `railties': uninitialized constant Rails::Application::Railties (NameError)
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:180:in `initializers'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/initializable.rb:49:in `run_initializers'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:134:in `initialize!'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:77:in `method_missing'
    from /Users/aonoryousuke/programming/web/aaa/config/environment.rb:5:in `<top (required)>'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:103:in `require'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/application.rb:103:in `require_environment!'
    from /Users/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-3.0.5/lib/rails/commands.rb:16:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'

と出ます。

カレントディレクトリの間違いはないです。
複数ファイルで検証して全部同じ結果だったので、ファイルの問題はないかと思われます

rubyのバージョンは2.4.1
railsのバージョンは3.0.5

OSはMacです。

宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

gem update --systemしたら直りました。
死ぬかと思った...

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

https://www.devalot.com/articles/2012/03/ror-compatibility

railsのバージョンは3.0.5

とのことなので
rails3.0系に対応したrubyのバージョンを調べると

1.8.7, 1.9.2, or 1.9.3

なので、ruby2.4では無謀ですね

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る