質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.90%

sassを使えるようになりたいのですが、インストールエラーが出ます。

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 2,126

score 12

sassを使えるようになりたいです。
macOSHighSierra、バージョン10.13.6、初心者です。

gem install sass

$sudo gem install sass
を入力すると以下のエラーが出てきます。

ERROR:  While executing gem ... (Gem::FilePermissionError)
You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.

となります。

また、
sass -v
では
-bash: sass: command not found
となります。

 試したこと

https://qiita.com/kolife/items/08d9abb02dcb189bebfc
を参考にXcodeをインストールしましたが、変化なし。

https://qiita.com/tokimari/items/feda1ed61f2d8b5b317c
を参考に
$ gem install hoge
-bash: $: command not found

$ rbenv versions
-bash: $: command not found

$ which gem
/usr/bin/gem

$ ruby -v
ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin17]

対処法の解る方、ご教授お願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2018/10/21 15:16

    ruby は、どのようにインストールしていますか?

    キャンセル

  • ffffujisan3776

    2018/10/21 15:28

    MacはRubyのインストールがされているという説明を数カ所で読みました。インストールはしていないと思います。

    キャンセル

回答 1

check解決した方法

0

見ていただいた方、ありがとうございました。
無事にSass、導入できました。

結果的には、、インストールしている場所が違ったのではないか、と思います。
Sassのためにターミナルを初めてさわったので、ディレクトリもさわれなかったのですが。。

以下、参考にして試した順です。

まず、出ていたエラーメッセージにて検索。

ERROR:  While executing gem ... (Gem::FilePermissionError)
You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.

「Compassのインストールに失敗するーteratail」
https://teratail.com/questions/109079

ベストアンサーを参考にリンク先の手順で、Ruby on Rails の環境を構築。

「誰でも出来るRuby on Railsの環境構築手順ーQiita」
https://qiita.com/sayama0402/items/9516e85fb4906eab9e72

「oh my zsh 導入手順ーログ」
http://ken-sayama.hateblo.jp/entry/2015/08/23/191743

XCode はインストール済でしたので、
homebrew、Oh my zsh 、Ruby を順にインストール。
インストールの確認をするも、エラーとなるので、エラーメッセージにて検索。

$ rails -v

Rails is not currently installed on this system. To get the latest version, simply type:

    $ sudo gem install rails

You can then rerun your "rails" command.

エラーメッセージで検索。
「無限 sudo gem install rails にハマりました」
http://tomoprog.hatenablog.com/entry/2017/02/03/015936

https://qiita.com/w7tree/items/0860e2856f2429b20eee

こちらの

export PATH="$HOME/.rbenv/bin:$PATH"

export PATH="$HOME/.rbenv/shims:$PATH"

を記述。
再度railsをインストール、バージョンが表示されました。
成功したので、sassも再インストール、バージョン表示OKでした!!!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.90%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る