質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.93%

Ruby on Rails をインストールしようとして gem install rails --no--ri --no-rdoc したら invalid option: --no--ri

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,726

takuya0122

score 13

 前提・実現したいこと

Windows環境にて、
Ruby on Rails をインストールしようと
コマンドプロンプトにて
C:\Ruby24\devkit>gem install rails --no--ri --no-rdoc
を実行しましたが、エラーが発生してインストールできません。

 発生している問題・エラーメッセージ

ERROR:  While executing gem ... (OptionParser::InvalidOption)
    invalid option: --no--ri

 該当のソースコード

gem install rails --no--ri --no-rdoc

 試したこと

rbenv rehash
を試してみた結果、
'rbenv' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

which gem
を試してみた結果、
'which' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

 補足情報(FW/ツールのバージョンなど)

C:\rubypj>ruby -v
ruby 2.4.4p296 (2018-03-28 revision 63013) [i386-mingw32]
C:\rubypj>rails -v
'rails' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+4

--no-riです。

また、--no-rdoc+--no-riをまとめて-Nなので

gem install rails -N
だけで十分です

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/10 12:31

    ありがとうございます。

    以下が実行したコマンドです。
    ```
    C:\Ruby24\devkit>gem install rails -N
    ```

    以下が実行結果です。
    ```
    Building native extensions. This could take a while...
    ERROR: Error installing rails:
    ERROR: Failed to build gem native extension.

    current directory: C:/Ruby24/lib/ruby/gems/2.4.0/gems/nio4r-2.3.1/ext/nio4r
    C:/Ruby24/bin/ruby.exe -r ./siteconf20181010-9456-1j4m7cj.rb extconf.rb

    current directory: C:/Ruby24/lib/ruby/gems/2.4.0/gems/nio4r-2.3.1/ext/nio4r
    make "DESTDIR=" clean
    'make' は、内部コマンドまたは外部コマンド、
    操作可能なプログラムまたはバッチ ファイルとして認識されていません。

    current directory: C:/Ruby24/lib/ruby/gems/2.4.0/gems/nio4r-2.3.1/ext/nio4r
    make "DESTDIR="
    'make' は、内部コマンドまたは外部コマンド、
    操作可能なプログラムまたはバッチ ファイルとして認識されていません。

    make failed, exit code 1

    Gem files will remain installed in C:/Ruby24/lib/ruby/gems/2.4.0/gems/nio4r-2.3.1 for inspection.
    Results logged to C:/Ruby24/lib/ruby/gems/2.4.0/extensions/x86-mingw32/2.4.0/nio4r-2.3.1/gem_make.out
    ```

    エラーとなったmakeをインストールすれば解決しますでしょうか。
    それとも、また別の問題でしょうか。

    よろしくお願い致します。

    キャンセル

  • 2018/10/10 12:43

    ridk install 1 2 3
    を先に実行してください

    キャンセル

  • 2018/10/10 13:06

    ご指摘の通り実行したら、あっさり解決できました!
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Rubyに関する質問
  • Ruby on Rails をインストールしようとして gem install rails --no--ri --no-rdoc したら invalid option: --no--ri