質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

Rails4から5系にアップデートする際にエラーが発生したGemをアップデートしたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 764

abab7200

score 118

表題の通りrails4系からrails5系にアップデートしようとしています。
その際にいくつかのgemでアップデートエラーとなります。

エラーが発生しているgemをアップデートしたいのですが、エラーが発生したgemのuptdate手順がわからないため
どなたかご教授いただければと存じます。

 blog git:(rails-Versionup) ✗ bundle update
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies..............

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    gon was resolved to 6.2.1, which depends on
      actionpack (>= 3.0)

    rails (= 5.1.5) was resolved to 5.1.5, which depends on
      actionpack (= 5.1.5)

    simple_form was resolved to 4.0.1, which depends on
      actionpack (>= 5.0)

Bundler could not find compatible versions for gem "activemodel":
  In Gemfile:
    rails (= 5.1.5) was resolved to 5.1.5, which depends on
      activemodel (= 5.1.5)

    web-console (~> 2.0) was resolved to 2.0.0, which depends on
      activemodel (~> 4.0)

Bundler could not find compatible versions for gem "activerecord":
  In Gemfile:
    rails (= 5.1.5) was resolved to 5.1.5, which depends on
      activerecord (= 5.1.5)

    ransack was resolved to 2.0.1, which depends on
      activerecord (>= 5.0)

以下gemファイル

# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '5.1.0'
gem 'mysql2'


gem 'sass-rails', '~> 5.0'
gem 'uglifier', '>= 1.3.0'

gem 'coffee-rails', '~> 4.1.0'

# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.0'
# bundle exec rake doc:rails generates the API under doc/api.
gem 'sdoc', '~> 0.4.0', group: :doc

gem 'config'

gem 'gon'

gem 'will_paginate', '~> 3.0.6'
gem 'will_paginate-bootstrap'
gem 'sidekiq', '~> 4.1.2'


gem 'devise'

# Social signup
gem 'omniauth-facebook'
gem 'omniauth-twitter'

gem 'yajl-ruby'

# Slim
gem 'slim'
gem 'font-awesome-sass'

# JQuery
gem 'jquery-rails'

# form
gem 'simple_form'

# Markdown
gem 'vuejs-rails', '1.0.26'
gem 'marked-rails'
gem 'redcarpet'
gem 'coderay'

# uploard
gem 'mini_magick'
gem 'aws-sdk', '< 2.0'
gem 'refile', '~> 0.6', require: 'refile/rails'
gem 'refile-mini_magick'

# Media image uploader for CMS
gem 'carrierwave'
gem 'paperclip', '~> 4.3'
gem 'rmagick', require: 'RMagick'

gem 'oauth'
gem 'twitter'

# Redis
gem 'redis'
gem 'redis-namespace'
gem 'redis-rails'

gem 'dotenv-rails'

# Site map
gem 'sitemap_generator'

#search
gem 'ransack'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • nocomment

    2018/09/27 00:02

    頻繁にアップグレードすると勘所が得られるのですが、言語化しずらいです。ケースバイケースなので。Gemfile も公開すると回答者も試せるので、差し支えなければ Gemfile の公開を。

    キャンセル

  • abab7200

    2018/09/27 09:25

    ありがとうございます。 gemの内容を追記しました

    キャンセル

回答 1

checkベストアンサー

0

bundlerのupdate時のバージョン解決アルゴリズムは、たまに変な挙動することがある気がしますね。
(或いは、エラーメッセージがおかしいのか…わかりませんが)

今回の例でいえば、gonのactionpackへの依存が広いことが原因なのかなぁ、と思います。
actionpackは5.1.5に解決すれば、エラーにある3つのgemのdependenciesが満たされるのが自明ですので、

  1. 仮で、Gemfileに `gem 'actionpack', '5.1.5'を追記
  2. bundle install
  3. bundle update
  4. Gemfileを元に戻し、もう一度bundle install

とかで、何か変化しないでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/10 23:28

    回答ありがとうございました! 引き続きエラーになるのですが、gemが複数versionインストールされているようです。
    別の質問としてアップします

    キャンセル

  • 2018/10/11 10:28

    およ。承知しました。
    (ただ、gemに複数インストールされていること、それ自体は、おそらく問題はないはず…)

    キャンセル

  • 2018/10/11 17:05

    マジっすか。。。 頂いた内容でもエラーになったのですが引き続き色々試してみて、解決しない場合は再度質問を投稿いたします。 お忙しい中ご回答いただきありがとうございました。

    キャンセル

  • 2018/10/12 10:57

    変化ありませんでしたか…むむむ。
    解決を祈っております。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる