質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.54%

verbose_query_logs

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 835

t.s_k

score 55

rails 5.1.6 でrails console を打つと以下のエラーが発生します。
verbose_query_logs=' for ActiveRecord をググったところ、5.2からの新機能のactive.storage 詳細
の情報が出るのですが、 rails new で5.1.6指定で作成しており、active.storage 関連の設定項目は全ファイル内でコメントアウト&削除しましたが、その後も rails console を打ち込む時だけ以下のエラーが出てしまいます。残ってる原因に何があるのか分かりません。
ご教授お願い致します。

$ rails version
Rails 5.1.6
$ rails console
/Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/dynamic_matchers.rb:22:in `method_missing': undefined method `verbose_query_logs=' for ActiveRecord::Bas
e:Class (NoMethodError)
        from /Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/railtie.rb:112:in `block (3 levels) in <class:Railtie>'
        from /Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/railtie.rb:111:in `each'
        from /Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/railtie.rb:111:in `block (2 levels) in <class:Railtie>'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:69:in `instance_eval'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:69:in `block in execute_hook'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:60:in `with_execution_control'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:65:in `execute_hook'

        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:50:in `block in run_load_hooks'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:49:in `each'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/lazy_load_hooks.rb:49:in `run_load_hooks'
        from /Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/base.rb:326:in `<module:ActiveRecord>'
        from /Library/Ruby/Gems/2.3.0/gems/activerecord-5.1.6/lib/active_record/base.rb:25:in `<main>'
        from /Library/Ruby/Gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
        from /Library/Ruby/Gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
        from /Library/Ruby/Gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
        from /Library/Ruby/Gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
        from /Library/Ruby/Gems/2.3.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:356:in `active_record_configured?'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:273:in `disconnect_database'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:107:in `preload'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:153:in `serve'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:141:in `block in run'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:135:in `loop'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application.rb:135:in `run'
        from /Library/Ruby/Gems/2.3.0/gems/spring-2.0.2/lib/spring/application/boot.rb:19:in `<top (required)>'
        from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from -e:1:in `<main>'
source 'https://rubygems.org'

gem 'rails',        '5.1.6'
gem 'puma',         '3.9.1'
gem 'sass-rails',   '5.0.6'
gem 'uglifier',     '3.2.0'
gem 'coffee-rails', '4.2.2'
gem 'jquery-rails', '4.3.1'
gem 'turbolinks',   '5.0.1'
gem 'jbuilder',     '2.7.0'

group :development, :test do
  gem 'sqlite3', '1.3.13'
  gem 'byebug',  '9.0.6', platform: :mri
end

group :development do
  gem 'web-console',           '3.5.1'
  gem 'listen',                '3.1.5'
  gem 'spring',                '2.0.2'
  gem 'spring-watcher-listen', '2.0.1'
end

group :test do
  gem 'rails-controller-testing', '1.0.2'
  gem 'minitest',                 '5.10.3'
  gem 'minitest-reporters',       '1.1.14'
  gem 'guard',                    '2.13.0'
  gem 'guard-minitest',           '2.4.4'
end

group :production do
  gem 'pg', '0.20.0'
end

# Windows環境ではtzinfo-dataというgemを含める必要があります
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

イメージ説明

app/envionments/depelopment.rb内のverbose(エラー吐いてた怪しいやつ)部分を
config.active_record.verbose_query_logs = false → コメントアウトしたら治りました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.54%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る