質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

vue.jsのプロジェクト作成

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 866

yyy_akk

score 7

 前提・実現したいこと

初歩的な質問なのですが、
vue.jsを使用し、新規でプロジェクトを作成したいのですが、「npm run dev」のコマンドをたたくと

 発生している問題・エラーメッセージ

> hello-vue@1.0.0 dev /Volumes/data/WorkingCopy/hello-vue
> webpack-dev-server --inline --progress --config build/webpack.dev.conf.js

 10% building modules 1/1 modules 0 activeevents.js:183                       i       throw er; // Unhandled 'error' event
      ^

Error: getaddrinfo ENOTFOUND localhost
    at errnoException (dns.js:50:10)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:92:26)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! hello-vue@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the hello-vue@1.0.0 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/○○○/.npm/_logs/2018-09-19T05_49_45_840Z-debug.log
EG233:hello-vue ○○○$ 


となってしまい、先に進めません。
/Users/○○○/.npm/_logs/2018-09-19T05_49_45_840Z-debug.log
こちらのファイルの中身は以下のようになっています。

EG233:hello-vue 〇〇○$ cat /Users/〇〇○/.npm/_logs/2018-09-19T05_49_45_840Z-debug.log
0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'run', 'dev' ]
2 info using npm@6.4.0
3 info using node@v8.11.4
4 verbose run-script [ 'predev', 'dev', 'postdev' ]
5 info lifecycle hello-vue@1.0.0~predev: hello-vue@1.0.0
6 info lifecycle hello-vue@1.0.0~dev: hello-vue@1.0.0
7 verbose lifecycle hello-vue@1.0.0~dev: unsafe-perm in lifecycle true
8 verbose lifecycle hello-vue@1.0.0~dev: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/Volumes/data/WorkingCopy/hello-vue/node_modules/.bin:/Users/〇〇○/.rbenv/shims:/Users/〇〇○/.rbenv/shims:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Users/〇〇○/.nodebrew/current/bin:/Users/〇〇○/.nodebrew/default/bin:/Users/〇〇○/.nodebrew/default/bin
9 verbose lifecycle hello-vue@1.0.0~dev: CWD: /Volumes/data/WorkingCopy/hello-vue
10 silly lifecycle hello-vue@1.0.0~dev: Args: [ '-c',
10 silly lifecycle   'webpack-dev-server --inline --progress --config build/webpack.dev.conf.js' ]
11 silly lifecycle hello-vue@1.0.0~dev: Returned: code: 1  signal: null
12 info lifecycle hello-vue@1.0.0~dev: Failed to exec dev script
13 verbose stack Error: hello-vue@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:304:16)
13 verbose stack     at emitTwo (events.js:126:13)
13 verbose stack     at EventEmitter.emit (events.js:214:7)
13 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack     at emitTwo (events.js:126:13)
13 verbose stack     at ChildProcess.emit (events.js:214:7)
13 verbose stack     at maybeClose (internal/child_process.js:925:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
14 verbose pkgid hello-vue@1.0.0
15 verbose cwd /Volumes/data/WorkingCopy/hello-vue
16 verbose Darwin 17.7.0
17 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "run" "dev"
18 verbose node v8.11.4
19 verbose npm  v6.4.0
20 error code ELIFECYCLE
21 error errno 1
22 error hello-vue@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`
22 error Exit status 1
23 error Failed at the hello-vue@1.0.0 dev script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]


何か心当たりがあったら教えていただけますでしょうか。
よろしくお願いいたします。

  • 追記
    webpackのバージョンを調べると(webpack-dev-server --version)以下のように表示されたのですがインストールされていないのですかね、、、
    (npm install webpack-dev-server --save-dev)こちらもやってみたのですが・・
Error: Cannot find module 'webpack'
    at Function.Module._resolveFilename (module.js:547:15)
    at Function.Module._load (module.js:474:25)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/local/lib/node_modules/webpack-dev-server/bin/webpack-dev-server.js:26:17)
    at Module._compile (module.js:652:30)
    at Object.Module._extensions..js (module.js:663:10)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • yyy_akk

    2018/09/20 09:44

    何度もすみません。上記のやり方でやってみたのですが同じエラーが発生し、念のためにhttp://westhillworker.com/npm-errors-first/こちらも試して見たのですが変わらずですね。。

    キャンセル

  • spookybird

    2018/09/20 13:38

    「出社」ということですが、社内で聞ける人はいないんでしょうか?package-lock.jsonの中でwebpack-dev-serverを探してバージョンを見てみてください。いくつですか?

    キャンセル

  • yyy_akk

    2018/09/20 14:26

    社内で詳しい人がおらず独学でやっている状態です・・バージョンは"2.11.3"となっておりました!

    キャンセル

回答 1

checkベストアンサー

0

https://github.com/vuejs-templates/webpack/issues/1229
これ参考になりませんかね。

バージョン違いますが

change webpack.dev.conf.js devServer options

devServer:{
inline:false,
...
}

とか、

For those who still stuck on this issue even after changing their version of node and npm, adding this line in my hosts file has solved the problem:
127.0.0.1 localhost

とか。

ただ、これ自体は2.10.0に対するissueで、このバグは

The problem have been resolved, you can now upgrade to the newest version of webpack (2.10.1).

とあるとおり2.10.1で修正済みのようです。

Nodeとnpmを最新バージョンにしてみてもいいかもしれません。
さすがにちょっとこれ以上は実際の環境いじらないとわからないですね...

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/09/21 09:29

    ありがとうございます!
    こちらの方法を試してみます!
    たくさん考えていただき、ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る